Bug 1307288 - OmegaT: FTBFS in rawhide
OmegaT: FTBFS in rawhide
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: OmegaT (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ismael Olea
Fedora Extras Quality Assurance
:
: 1239346 (view as bug list)
Depends On: 1201292
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 15:57 EST by Fedora Release Engineering
Modified: 2016-11-18 05:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-18 05:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (232.04 KB, text/plain)
2016-02-13 15:57 EST, Fedora Release Engineering
no flags Details
root.log (112.34 KB, text/plain)
2016-02-13 15:57 EST, Fedora Release Engineering
no flags Details
state.log (617 bytes, text/plain)
2016-02-13 15:57 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 15:57:49 EST
Your package OmegaT failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12804538

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 15:57:52 EST
Created attachment 1123934 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 15:57:53 EST
Created attachment 1123935 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 15:57:54 EST
Created attachment 1123936 [details]
state.log
Comment 4 Yaakov Selkowitz 2016-02-19 16:31:03 EST
Cause appears to be API changes in eclipse-jgit 4.x.
Comment 5 Jan Kurik 2016-02-24 09:32:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Peter Robinson 2016-08-12 18:03:16 EDT
*** Bug 1239346 has been marked as a duplicate of this bug. ***
Comment 7 Peter Robinson 2016-08-12 18:04:27 EDT
(In reply to Yaakov Selkowitz from comment #4)
> Cause appears to be API changes in eclipse-jgit 4.x.

Possibly fixed upstream. Maintainer can you please update/fix or retire the package?
Comment 8 Ismael Olea 2016-08-28 17:21:42 EDT
Upstream efectively has updated to eclipse-jit 4.* (https://sourceforge.net/p/omegat/code/ci/master/tree/lib/auto/). The problem is they use a zillion of other new dependencies and is too hard to bring all to Fedora :-/

I'm seriously considering to retire the package.
Comment 9 Ismael Olea 2016-11-18 05:06:03 EST
OmegaT is so hard to keep update that I'm in the process of migrating to flatpak.

Sorry inconveniences.

Note You need to log in before you can comment on or make changes to this bug.