Bug 1307301 - Singular: FTBFS in rawhide
Singular: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Singular (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paulo Andrade
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 15:59 EST by Fedora Release Engineering
Modified: 2016-02-23 12:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 12:38:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (313.70 KB, text/plain)
2016-02-13 15:59 EST, Fedora Release Engineering
no flags Details
root.log (167.70 KB, text/plain)
2016-02-13 15:59 EST, Fedora Release Engineering
no flags Details
state.log (629 bytes, text/plain)
2016-02-13 15:59 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 15:59:03 EST
Your package Singular failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12805242

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 15:59:06 EST
Created attachment 1123973 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 15:59:07 EST
Created attachment 1123974 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 15:59:08 EST
Created attachment 1123975 [details]
state.log
Comment 4 Yaakov Selkowitz 2016-02-23 12:31:31 EST
mod_raw.cc: In function 'lib_types type_of_LIB(char*, char*)':
mod_raw.cc:40:45: error: narrowing conversion of '254' from 'int' to 'char' inside { } [-Wnarrowing]
   const char mach_o[]={0xfe,0xed,0xfa,0xce,0};
mod_raw.cc:40:45: error: narrowing conversion of '237' from 'int' to 'char' inside { } [-Wnarrowing]
mod_raw.cc:40:45: error: narrowing conversion of '250' from 'int' to 'char' inside { } [-Wnarrowing]
mod_raw.cc:40:45: error: narrowing conversion of '206' from 'int' to 'char' inside { } [-Wnarrowing]
mod_raw.cc:41:52: error: narrowing conversion of '206' from 'int' to 'char' inside { } [-Wnarrowing]
   const char mach_o_module[]={0xce,0xfa,0xed,0xfe,0};
                                                    ^
mod_raw.cc:41:52: error: narrowing conversion of '250' from 'int' to 'char' inside { } [-Wnarrowing]
mod_raw.cc:41:52: error: narrowing conversion of '237' from 'int' to 'char' inside { } [-Wnarrowing]
mod_raw.cc:41:52: error: narrowing conversion of '254' from 'int' to 'char' inside { } [-Wnarrowing]

Looks like these should be const unsigned char[].
Comment 5 Rex Dieter 2016-02-23 12:38:20 EST
Thanks, looks like that fix is already included in
http://koji.fedoraproject.org/koji/buildinfo?buildID=737442

Note You need to log in before you can comment on or make changes to this bug.