Bug 1307340 - baloo: FTBFS in rawhide
baloo: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: baloo (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:03 EST by Fedora Release Engineering
Modified: 2016-02-19 15:19 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 15:19:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (63.87 KB, text/plain)
2016-02-13 16:03 EST, Fedora Release Engineering
no flags Details
root.log (136.54 KB, text/plain)
2016-02-13 16:03 EST, Fedora Release Engineering
no flags Details
state.log (617 bytes, text/plain)
2016-02-13 16:03 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:03:36 EST
Your package baloo failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12807350

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:03:42 EST
Created attachment 1124090 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:03:45 EST
Created attachment 1124091 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:03:48 EST
Created attachment 1124092 [details]
state.log
Comment 4 Yaakov Selkowitz 2016-02-16 23:11:08 EST
src/pim/akonadiplugin/searchplugin.h has a #include <akonadi/abstractsearchplugin.h>, but this header is no longer included in akonadi-devel since http://pkgs.fedoraproject.org/cgit/rpms/akonadi.git/commit/?id=04ca9f646e051af28fd8079aeab222231e8299aa
Comment 5 Rex Dieter 2016-02-17 08:31:05 EST
thanks for the hint.

pondering this, I'm considering simply omitting most or all of the stuff under baloo/src/pim, which includes:
agent/
akonadiplugin/
lib/
search/

seems a small few packages still link libbaloopim
Comment 6 Rex Dieter 2016-02-17 13:17:06 EST
Heck, we may even be able to retire baloo altogether
Comment 7 Rex Dieter 2016-02-19 15:19:16 EST
I guess we'll keep it around a little while longer,


%changelog
* Fri Feb 19 2016 Rex Dieter <rdieter@fedoraproject.org> - 4.14.3-7
- omit akonadi/pim related bits (f24+)
- baloo FTBFS on rawhide (#1307340)

Note You need to log in before you can comment on or make changes to this bug.