Bug 1307342 - barcode: FTBFS in rawhide
barcode: FTBFS in rawhide
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: barcode (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:03 EST by Fedora Release Engineering
Modified: 2016-03-07 15:12 EST (History)
4 users (show)

See Also:
Fixed In Version: barcode-0.98-27.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 15:12:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (67.03 KB, text/plain)
2016-02-13 16:03 EST, Fedora Release Engineering
no flags Details
root.log (107.53 KB, text/plain)
2016-02-13 16:04 EST, Fedora Release Engineering
no flags Details
state.log (621 bytes, text/plain)
2016-02-13 16:04 EST, Fedora Release Engineering
no flags Details
Patch for rawhide and f24 (1.52 KB, patch)
2016-02-24 16:35 EST, Yaakov Selkowitz
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:03:55 EST
Your package barcode failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12807427

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:03:58 EST
Created attachment 1124096 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:04:00 EST
Created attachment 1124097 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:04:01 EST
Created attachment 1124098 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:34:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Yaakov Selkowitz 2016-02-24 16:35 EST
Created attachment 1130334 [details]
Patch for rawhide and f24

- Fix F24FTBFS caused by docs shipped in tarball (#1307342)
- Fix build of HTML documenation

This was interesting, to say the least.  The actual error occured while 
building docs:

old="`ls barcode.??~ barcode.aux~ | sed 's/~//g'`"; \
new="`ls barcode.?? barcode.aux`"; \
need="n"; \
if test "$old" != "$new"; then need="y"; \
else \
  for i in  `ls barcode.?? barcode.aux`; do \
    cmp -s $i $i~; if test $? -ne 0; then need="y" break; fi; \
  done; \
fi; \
if test "$need" = "y"; then \
  texindex barcode.?? && tex barcode.texinfo; \
fi
ls: cannot access 'barcode.aux~': No such file or directory
barcode.ps is not a Texinfo index file

I'm guessing that something changed in texindex, because this used to
work, but the prebuilt doc/barcode.ps is throwing it off now.  Cleaning
in doc/ before building fixes the issue.

I also discovered that the HTML docs were not being built properly.
Configure was doing the following, in short:

${MAKEINFO=makeinfo} --help | grep .--html > /dev/null
INFOTOHTML="$MAKEINFO --html"

The idea was that configure would set MAKEINFO to "makeinfo" if not 
already defined, but the ${parameter=word} expansion doesn't do that 
when output is redirected.  Nor am I sure if this is intentional or a 
bug; going all the way back in Koji logs to F9 (bash-3.2) and EPEL4 
(bash-3.0), it didn't work back then either.

So here is a patch for rawhide and f24 (which was just branched) that 
fixes both.
Comment 6 Upstream Release Monitoring 2016-03-07 14:50:38 EST
yselkowitz's barcode-0.98-27.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=742717

Note You need to log in before you can comment on or make changes to this bug.