Bug 1307375 - chicken: FTBFS in rawhide
chicken: FTBFS in rawhide
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: chicken (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ricky Elrod
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:07 EST by Fedora Release Engineering
Modified: 2016-08-16 21:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-16 21:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (92.56 KB, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details
root.log (80.19 KB, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details
state.log (625 bytes, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:07:41 EST
Your package chicken failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12809162

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:07:44 EST
Created attachment 1124195 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:07:45 EST
Created attachment 1124196 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:07:46 EST
Created attachment 1124197 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:36:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Yaakov Selkowitz 2016-02-24 21:40:09 EST
install -m 644 ./chicken.h "/builddir/build/BUILDROOT/chicken-4.10.0-2.fc24.x86_64/usr/include/chicken/chicken"
install -m 644 chicken-config.h "/builddir/build/BUILDROOT/chicken-4.10.0-2.fc24.x86_64/usr/include/chicken/chicken"
[snip]
    File not found: /builddir/build/BUILDROOT/chicken-4.10.0-2.fc24.x86_64/usr/include/chicken/chicken-config.h
    File not found: /builddir/build/BUILDROOT/chicken-4.10.0-2.fc24.x86_64/usr/include/chicken/chicken.h

Looks like the INCLUDEDIR=%{_includedir}/chicken in %build and %install is superfluous and should either be removed or changed to INCLUDEDIR=%{_includedir}.
Comment 6 Upstream Release Monitoring 2016-07-07 06:52:38 EDT
codeblock's chicken-4.11.0-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=777826
Comment 7 Upstream Release Monitoring 2016-07-08 05:52:03 EDT
codeblock's chicken-4.11.0-2.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=778680
Comment 8 Ricky Elrod 2016-08-16 21:03:48 EDT
4.11 is in rawhide and built successfully. Closing this for now.

Note You need to log in before you can comment on or make changes to this bug.