Bug 1307376 - chocolate-doom: FTBFS in rawhide
chocolate-doom: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: chocolate-doom (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:07 EST by Fedora Release Engineering
Modified: 2016-11-06 16:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-06 16:41:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (42.15 KB, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details
root.log (106.48 KB, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details
state.log (653 bytes, text/plain)
2016-02-13 16:07 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:07:46 EST
Your package chocolate-doom failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12809210

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:07:49 EST
Created attachment 1124198 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:07:50 EST
Created attachment 1124199 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:07:51 EST
Created attachment 1124200 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:36:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Yaakov Selkowitz 2016-02-24 21:41:41 EST
error: Installed (but unpackaged) file(s) found:
   /usr/share/doc/chocolate-doom/CMDLINE.doom
   /usr/share/doc/chocolate-doom/INSTALL.doom
   /usr/share/doc/chocolate-doom/PHILOSOPHY
   /usr/share/doc/chocolate-doom/README.Music

Looks like make install is installing some files that are not accounted for in %doc.  Either they need to be %doc'd, and/or a rm -fr $RPM_BUILD_ROOT%{_pkgdocdir} in %install is in order.

Note You need to log in before you can comment on or make changes to this bug.