Bug 1307381 - clipper: FTBFS in rawhide
clipper: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clipper (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Fenn
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:08 EST by Fedora Release Engineering
Modified: 2016-03-26 14:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: clipper-2.1-20150701.1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (97.40 KB, text/plain)
2016-02-13 16:08 EST, Fedora Release Engineering
no flags Details
root.log (81.20 KB, text/plain)
2016-02-13 16:08 EST, Fedora Release Engineering
no flags Details
state.log (653 bytes, text/plain)
2016-02-13 16:08 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:08:22 EST
Your package clipper failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12809407

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:08:24 EST
Created attachment 1124213 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:08:25 EST
Created attachment 1124214 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:08:26 EST
Created attachment 1124215 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:36:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Yaakov Selkowitz 2016-02-24 21:57:43 EST
spacegroup_data.cpp:198:1: error: narrowing conversion of '2610067359u' from 'unsigned int' to 'int' inside { } [-Wnarrowing]
spacegroup_data.cpp:198:1: error: narrowing conversion of '2962048719u' from 'unsigned int' to 'int' inside { } [-Wnarrowing]
[snip]

It looks like LGdata.lghash and SGdata.sghash can be unsigned int.
Comment 6 Fedora Update System 2016-03-13 16:14:50 EDT
clipper-2.1-1.20150701.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6630e42523
Comment 7 Fedora Update System 2016-03-14 08:03:24 EDT
clipper-2.1-20150701.1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-02b21a4814
Comment 8 Fedora Update System 2016-03-15 17:31:49 EDT
clipper-2.1-20150701.1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-02b21a4814
Comment 9 Fedora Update System 2016-03-26 14:09:07 EDT
clipper-2.1-20150701.1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.