Bug 13074 - QA0327: mouseconfig fails to set 3 button emulation
QA0327: mouseconfig fails to set 3 button emulation
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-26 15:09 EDT by Adrian Likins
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2000-06-26 15:09:14 EDT
Did an upgrade from 6.2 to beta2 on a dell inspiron 3500
with a 2 button ps2 touch pad. 

After starting X, there was no way to get a middle click,
and emulate three buttons doesnt seem to work. 

Not sure what it should be adding to the XF86Config, as
that man page is incorrect, but thats another bug report.
Comment 1 Trond Eivind Glomsrxd 2000-08-06 19:31:51 EDT
Please update status with RC1
Comment 2 Eugene Kanter 2001-03-28 19:29:12 EST
This is still not working in QA0327: /etc/X11/XF86Config does not get updated,
although the file timestamp changes.
mouseconfig-4.19-1
Comment 3 Trond Eivind Glomsrxd 2001-03-29 14:09:32 EST
It works in 4.20, which has no fixes in that area (it's just compiled with a 
new kudzu)
Comment 4 Eugene Kanter 2001-04-01 23:13:53 EDT
part 1:
# rpm -q mouseconfig
mouseconfig-4.20-1
# tail -1 /etc/sysconfig/mouse
XEMU3=no
# mouseconfig
(box is not checked. check the box and OK to all)
# tail -1 /etc/sysconfig/mouse
XEMU3=yes
# mouseconfig
(box is checked. uncheck the box and OK to all)
# tail -1 /etc/sysconfig/mouse
XEMU3=yes
# mouseconfig
(the box is checked. seems like uncheck is ignored)

Part 2 (about XF86Config) may follow after part 1 is fixed.
Comment 5 Eugene Kanter 2001-04-05 12:11:56 EDT
QA0401: no changes. look here:

edit /etc/sysconfig/mouse, update XEMU3=no
start mouseconfig, observe emulate3buttons  box is not checked.

hit enter two times.
open /etc/sysconfig/mouse: XEMU3=yes !!!!!! What is going on???
Comment 6 Matt Wilson 2001-04-05 12:34:24 EDT
do you have a 2 button mouse model selected?
Comment 7 Eugene Kanter 2001-04-07 14:31:43 EDT
yes, PS/2 generic
Comment 8 Matt Wilson 2001-04-07 15:09:32 EDT
select one of the "3 button" versions
Comment 9 Eugene Kanter 2001-04-07 17:01:19 EDT
What are you trying to tell me? That 2 button mouse unconditionally selects 3 
button emulation? I _might_ agree with that. But mouseconfig would better tell 
users about it or let unselect if they _really_ want.

Now part two:

This is the default Pointer section after mouseconfig selecting emulation to no

Section "Pointer"
    Protocol    "PS/2"
    Device      "/dev/mouse"
#    Emulate3Buttons
#    Emulate3Timeout    50
EndSection


Looks good!

Now here is someone's Pointer section, made by hand:

Section "Pointer"
    Protocol    "PS/2"
    Device      "/dev/mouse"
EndSection

This makes mouseconfig very confused and it CAN NOT enable 3 button 
emulation!!! This is a _real_ bug.

Comment 10 Brent Fox 2002-10-10 14:14:39 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 11 Eugene Kanter 2002-10-10 14:32:00 EDT
as longs as some kind of configuration is awailable in text mode....
Comment 12 Brent Fox 2002-10-10 23:26:55 EDT
Yeah.  Like I said, the new text mode interface for redhat-config-mouse looks
just like mouseconfig.  The benefit is that the GUI and TUI share the same
backend, so we don't have to maintain two separate tools to do the exact same thing.
Comment 13 Red Hat Bugzilla 2006-02-21 13:47:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.