Bug 1307441 - eigen2: FTBFS in rawhide
eigen2: FTBFS in rawhide
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eigen2 (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:15 EST by Fedora Release Engineering
Modified: 2016-11-06 18:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-06 18:12:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (237.07 KB, text/plain)
2016-02-13 16:15 EST, Fedora Release Engineering
no flags Details
root.log (157.85 KB, text/plain)
2016-02-13 16:15 EST, Fedora Release Engineering
no flags Details
state.log (621 bytes, text/plain)
2016-02-13 16:15 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:15:20 EST
Your package eigen2 failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12813644

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:15:23 EST
Created attachment 1124393 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:15:24 EST
Created attachment 1124394 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:15:25 EST
Created attachment 1124395 [details]
state.log
Comment 4 Yaakov Selkowitz 2016-02-16 11:54:37 EST
FWIW, 'Eigen::AmbiVector<_Scalar>::nonZeros() const' was eventually changed to return int, among other (possibly unrelated) changes:

https://bitbucket.org/eigen/eigen/commits/a99c2fa786e791e9ad1ef23b247e71ebd3367164
Comment 5 Rex Dieter 2016-02-16 11:59:25 EST
Turns out eigen2 was deprecated by upstream quite awhile ago, and nothing in fedora still depends on it.

I'm leaning towards retirement
Comment 6 Yaakov Selkowitz 2016-02-16 12:42:56 EST
(In reply to Rex Dieter from comment #5)
> I'm leaning towards retirement

IIRC the KDE4 kdeplasma-addons BR'd it, but I guess anyone with that in a copr will just have to maintain eigen2 themselves (or drop whichever feature required it).
Comment 7 Fedora Admin XMLRPC Client 2016-02-16 13:13:19 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Rex Dieter 2016-02-16 13:23:11 EST
Went the orphan route, to make it easier for someone else to pick it up
Comment 9 Jan Kurik 2016-02-24 09:39:05 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.