Bug 1307507 - flrig: FTBFS in rawhide
flrig: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: flrig (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Shaw
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:22 EST by Fedora Release Engineering
Modified: 2016-02-17 12:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 12:04:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (110.19 KB, text/plain)
2016-02-13 16:22 EST, Fedora Release Engineering
no flags Details
root.log (89.74 KB, text/plain)
2016-02-13 16:22 EST, Fedora Release Engineering
no flags Details
state.log (617 bytes, text/plain)
2016-02-13 16:22 EST, Fedora Release Engineering
no flags Details
proposed patch (1.49 KB, patch)
2016-02-17 07:26 EST, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:22:09 EST
Your package flrig failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12815733

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:22:11 EST
Created attachment 1124585 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:22:12 EST
Created attachment 1124586 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:22:13 EST
Created attachment 1124587 [details]
state.log
Comment 4 Ralf Corsepius 2016-02-17 07:26 EST
Created attachment 1127928 [details]
proposed patch

This FTBFS is caused by a symbol clash between a file-local variable "ignore" and std::ignore, which is exposed by this package using "using namespace std;" in its files.

A proper fix would be to eliminate all "using namespace std;" or to rename the offending variable.

The patch (against Fedora's spec in git master) implements the latter, because it's less intrusive and therefore seems more appropriate as a sort term work-around for a package to me.
Comment 5 Richard Shaw 2016-02-17 12:04:05 EST
Thanks for the quick fix. Applied and built. I have reported it upstream as well.

http://koji.fedoraproject.org/koji/taskinfo?taskID=13024283

Note You need to log in before you can comment on or make changes to this bug.