Bug 1307616 - hex-a-hop: FTBFS in rawhide
hex-a-hop: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hex-a-hop (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:34 EST by Fedora Release Engineering
Modified: 2016-03-29 15:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: hex-a-hop-1.2.0-0.4.20140926git3bad56e.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 15:34:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (48.54 KB, text/plain)
2016-02-13 16:34 EST, Fedora Release Engineering
no flags Details
root.log (117.70 KB, text/plain)
2016-02-13 16:34 EST, Fedora Release Engineering
no flags Details
state.log (685 bytes, text/plain)
2016-02-13 16:34 EST, Fedora Release Engineering
no flags Details
Patch to fix the FTBFS (1.78 KB, patch)
2016-03-17 13:55 EDT, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:34:46 EST
Your package hex-a-hop failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12822806

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:34:48 EST
Created attachment 1124912 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:34:49 EST
Created attachment 1124913 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:34:50 EST
Created attachment 1124914 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:47:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Ralf Corsepius 2016-03-17 13:55 EDT
Created attachment 1137451 [details]
Patch to fix the FTBFS

This FTBFS is caused by the package mixing "%doc <relative path>"
and direct doc installation. 
This is not supported in newer version of rpm, anymore.

This patch in the attachment (against git/master) changes the package to directly install all doc-files into %{_pkgdocdir}. Additionally, the patch also addresses RHBZ#1318756.

Unless somebody objects, I indent to apply this patch in near future.
Comment 6 Ralf Corsepius 2016-03-22 08:11:53 EDT
Taking.
Comment 7 Mario Blättermann 2016-03-22 08:18:14 EDT
@Ralf, please have a look at this:
https://bugzilla.redhat.com/show_bug.cgi?id=1318756

Maybe you can change also the NVR-scheme, but I'm not sure if it is correct. I'm afraid it would break the upgrade path.
Comment 8 Ralf Corsepius 2016-03-22 13:11:49 EDT
The upgrade path should be safe:

# rpmver 1.2.0-0.4.20140926git3bad56e.fc25 1.2.0-git20140926.4.fc25.3
1.2.0-0.4.20140926git3bad56e.fc25 is newer

# rpmver 1.2.0-0.4.20140926git3bad56e.fc25 1.2.0-git20140926.4.fc24.3
1.2.0-0.4.20140926git3bad56e.fc25 is newer

# rpmver 1.2.0-0.4.20140926git3bad56e.fc25 1.2.0-0.4.20140926git3bad56e.fc24
1.2.0-0.4.20140926git3bad56e.fc25 is newer
Comment 9 Fedora Update System 2016-03-22 23:33:16 EDT
hex-a-hop-1.2.0-0.4.20140926git3bad56e.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4b318299c0
Comment 10 Fedora Update System 2016-03-23 15:56:13 EDT
hex-a-hop-1.2.0-0.4.20140926git3bad56e.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4b318299c0
Comment 11 Fedora Update System 2016-03-29 15:34:36 EDT
hex-a-hop-1.2.0-0.4.20140926git3bad56e.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.