Bug 1307617 - highlight: FTBFS in rawhide
highlight: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: highlight (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:34 EST by Fedora Release Engineering
Modified: 2016-09-16 20:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: highlight-3.31-1.fc24 highlight-3.31-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-16 19:20:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (34.85 KB, text/plain)
2016-02-13 16:34 EST, Fedora Release Engineering
no flags Details
root.log (99.91 KB, text/plain)
2016-02-13 16:34 EST, Fedora Release Engineering
no flags Details
state.log (625 bytes, text/plain)
2016-02-13 16:34 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:34:51 EST
Your package highlight failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12822945

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:34:53 EST
Created attachment 1124915 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:34:56 EST
Created attachment 1124916 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:34:58 EST
Created attachment 1124917 [details]
state.log
Comment 4 Dan Horák 2016-02-18 09:14:08 EST
from build.log
...
ar: libhighlight.a: Malformed archiv

this is similar to issues we saw with kernel builds on ppc and s390, seems to be related to some parallel make or file access. I have just fixed same issue in highlight on s390 by resubmitting the build.
Comment 5 Jan Kurik 2016-02-24 09:47:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Filipe Rosset 2016-05-17 22:53:51 EDT
despite the fact that I did a lot of testing / mock compilations against x86_64 (through all f22, f23, f24 and rawhide releases), unfortunately i686 looks broken, I'll take a look further soon.
Comment 7 Dan Horák 2016-05-18 04:30:00 EDT
The code doesn't seem to be broken, it's the buildsystem. Try with disabling parallel make/build.
Comment 8 Fedora Admin XMLRPC Client 2016-07-29 16:40:21 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Kevin Fenzi 2016-07-29 17:34:14 EDT
Looks like this was fixed by disabling parallel build?
Comment 10 Dan Horák 2016-07-29 17:54:27 EDT
IIRC no one touched the spec, just trying the build couple times and it passes at the end. But disabling parallel build would be safer.
Comment 11 Kevin Fenzi 2016-07-29 18:00:12 EDT
Well, looks to me like Filipe did: 

commit e740489f06bef8c2a4215944239ce7dd90596d07
Author: Filipe Rosset <rosset.filipe@gmail.com>
Date:   Sat May 21 19:34:14 2016 -0300

    Disable paralell builds, atempt to fixes FTBFS rhbz #1307617
Comment 12 Fedora Update System 2016-09-13 23:49:33 EDT
highlight-3.31-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-be1e1efbcc
Comment 13 Fedora Update System 2016-09-13 23:49:43 EDT
highlight-3.31-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9a87a34f23
Comment 14 Fedora Update System 2016-09-14 16:56:30 EDT
highlight-3.31-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9a87a34f23
Comment 15 Fedora Update System 2016-09-14 17:23:58 EDT
highlight-3.31-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-be1e1efbcc
Comment 16 Fedora Update System 2016-09-16 19:20:34 EDT
highlight-3.31-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-09-16 20:57:42 EDT
highlight-3.31-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.