This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1307737 - libseccomp: FTBFS in F24
libseccomp: FTBFS in F24
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libseccomp (Show other bugs)
24
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Moore
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:48 EST by Fedora Release Engineering
Modified: 2016-02-29 16:43 EST (History)
1 user (show)

See Also:
Fixed In Version: libseccomp-2.3.0-0.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 16:43:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (487.51 KB, text/plain)
2016-02-13 16:48 EST, Fedora Release Engineering
no flags Details
root.log (80.64 KB, text/plain)
2016-02-13 16:48 EST, Fedora Release Engineering
no flags Details
state.log (633 bytes, text/plain)
2016-02-13 16:48 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:48:17 EST
Your package libseccomp failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12832155

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:48:19 EST
Created attachment 1125272 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:48:21 EST
Created attachment 1125273 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:48:23 EST
Created attachment 1125274 [details]
state.log
Comment 4 Paul Moore 2016-02-15 16:42:44 EST
This is most likely due to the build system running kernel-4.3.4-300.fc23.x86_64.  There is a known problem with kernels >= 4.3.x and current releases of libseccomp due to the direct wired socket syscalls that were introduced in Linux 4.3.  We have resolved the problem upstream and are working quickly to create a new release.

 * https://github.com/seccomp/libseccomp/issues/21
Comment 5 Jan Kurik 2016-02-24 09:52:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Paul Moore 2016-02-29 16:43:48 EST
We've released a new version upstream which should resolve this problem; an updated libseccomp package is now available for F24.

 * https://github.com/seccomp/libseccomp/releases/tag/v2.3.0

Note You need to log in before you can comment on or make changes to this bug.