Bug 1307746 - lilypond: FTBFS in rawhide
lilypond: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lilypond (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:49 EST by Fedora Release Engineering
Modified: 2016-03-02 14:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 14:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (74.00 KB, text/plain)
2016-02-13 16:49 EST, Fedora Release Engineering
no flags Details
root.log (367.26 KB, text/plain)
2016-02-13 16:49 EST, Fedora Release Engineering
no flags Details
state.log (633 bytes, text/plain)
2016-02-13 16:49 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:49:14 EST
Your package lilypond failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12833021

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:49:17 EST
Created attachment 1125299 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:49:18 EST
Created attachment 1125300 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:49:19 EST
Created attachment 1125301 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:53:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Yaakov Selkowitz 2016-02-25 11:51:24 EST
./include/smobs.tcc:143:37: error: invalid conversion from 'int' to 'const char*' [-fpermissive]
       SCM subr = scm_c_define_gsubr (Super::type_p_name_, 1, 0, 0,
                  ~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                      (scm_t_subr) smob_p);
                                      ~~~~~~~~~~~~~~~~~~~~
/usr/include/libguile/gsubr.h:47:13: note:   initializing argument 1 of 'scm_unused_struct* scm_c_define_gsubr(const char*, int, int, int, scm_unused_struct* (*)())'
 SCM_API SCM scm_c_define_gsubr (const char *name,
             ^~~~~~~~~~~~~~~~~~
In file included from ./include/smobs.hh:367:0,
                 from ./include/input.hh:24,
                 from ./include/translator.hh:26,
                 from ./include/engraver.hh:24,
                 from ./include/engraver-group.hh:23,
                 from ./include/score-engraver.hh:23,
                 from score-engraver.cc:20:
./include/smobs.tcc:147:37: error: invalid initialization of reference of type 'const string& {aka const std::__cxx11::basic_string<char>&}' from expression of type 'const int'
       ly_add_function_documentation (subr, Super::type_p_name_, "(SCM x)",
       ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                      fundoc);
                                      ~~~~~~~
./include/lily-guile-macros.hh:142:6: note: in passing argument 2 of 'void ly_add_function_documentation(SCM, const string&, const string&, const string&)'
 void ly_add_function_documentation (SCM proc, const string &fname, const string &varlist, const string &doc);
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./include/smobs.tcc:149:20: error: invalid conversion from 'int' to 'const char*' [-fpermissive]
       scm_c_export (Super::type_p_name_, NULL);
       ~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/include/libguile/modules.h:90:14: note:   initializing argument 1 of 'void scm_c_export(const char*, ...)'
 SCM_API void scm_c_export (const char *name, ...);
              ^~~~~~~~~~~~

Looks like 0 is being used in place of NULL in Super::type_p_name_.
Comment 6 Upstream Release Monitoring 2016-03-02 13:55:56 EST
limb's lilypond-2.19.37-2.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=741038
Comment 7 Gwyn Ciesla 2016-03-02 14:03:59 EST
Thanks, I fixed that, some narrowing conversions and type weirdness.

Note You need to log in before you can comment on or make changes to this bug.