Bug 130776 - gnome-python2-applet causes seg fault when testcode run
Summary: gnome-python2-applet causes seg fault when testcode run
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-python2   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-24 16:43 UTC by Edward Rousseau
Modified: 2015-04-12 23:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 20:39:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from gnome-python2-applet (1.30 KB, text/plain)
2004-08-24 18:36 UTC, Edward Rousseau
no flags Details

Description Edward Rousseau 2004-08-24 16:43:00 UTC
Description of problem: While doing U3 errata testing for the newly
added gnome-python2-applet, executing the testcode causes a seg fault
both remote X and locally.


Version-Release number of selected component (if applicable):
gnome-python2-applet-1.99.14-5

How reproducible: Always


Steps to Reproduce:
1. log into the desktop and open a terminal.
2. execute the following testcode:

% python
>>> import gtk
>>> import gnome.applet
>>> gnome.applet.Applet()

3.
  
Actual results:
Seg Fault

Expected results:
nothing blows up. applet created.

Additional info:

Comment 2 Edward Rousseau 2004-08-24 18:36:15 UTC
Created attachment 103035 [details]
backtrace from gnome-python2-applet

Backtrace from i386

Comment 3 Jeremy Katz 2004-08-24 18:40:16 UTC
Just for sanity sake -- you're running on a box with a valid DISPLAY
that's running a GNOME desktop, yes?  (And more preferably, a RHEL3
gnome desktop)

Comment 4 Edward Rousseau 2004-08-24 19:04:27 UTC
Yes, this fails on the stable systems in RDU remotely and I had dkl
test them locally. It seg faults in either case. Other apps forward
and come up correctly for me here (mozilla, xterm, gedit).

Comment 5 Jeremy Katz 2004-08-24 19:17:52 UTC
Yeah, but applets are "special" since they depend on more than just a
display.  So if you're not running it all on the same machine (ie, the
whole desktop run from one box), I wouldn't be surprised if it failed.  

(Discounting doing wacky things like turning on ORBit over tcp/ip)

Comment 6 Jonathan Blandford 2004-08-24 19:59:22 UTC
Looks like the problem was with the test case.  older gnome-python
weren't robust against instantiation w/o a bonobo factory to go with
them.  It seems to work fine w/ a normal applet, but not the given
test case


Note You need to log in before you can comment on or make changes to this bug.