Bug 1307763 - masscan: FTBFS in rawhide
masscan: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: masscan (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:51 EST by Fedora Release Engineering
Modified: 2017-02-25 20:36 EST (History)
2 users (show)

See Also:
Fixed In Version: masscan-1.0.3-7.fc24 masscan-1.0.3-7.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-25 19:20:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (6.56 KB, text/plain)
2016-02-13 16:51 EST, Fedora Release Engineering
no flags Details
root.log (80.84 KB, text/plain)
2016-02-13 16:51 EST, Fedora Release Engineering
no flags Details
state.log (621 bytes, text/plain)
2016-02-13 16:51 EST, Fedora Release Engineering
no flags Details
proposed patch (1.45 KB, patch)
2016-03-19 02:26 EDT, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:51:00 EST
Your package masscan failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12834417

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:51:02 EST
Created attachment 1125350 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:51:02 EST
Created attachment 1125351 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:51:03 EST
Created attachment 1125352 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:54:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Ralf Corsepius 2016-03-19 02:26 EDT
Created attachment 1137970 [details]
proposed patch

This package FTBFSes because of a gcc-version check which rejects gcc-6.

Upstream seems to have addressed this issue (and more) in later git-versions of this package.

Therefore, I am recommending to upgrade to this package to upstream's git/master in this case. The patch in the attachment contains the diff of masscan.spec of how I would implement it.

Scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=13387664

Unless somebody objects, I intend to apply a full update in near future.
Comment 6 Upstream Release Monitoring 2017-02-16 12:09:49 EST
corsepiu's masscan-1.0.3-7.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=859730
Comment 7 Fedora Update System 2017-02-17 04:18:25 EST
masscan-1.0.3-7.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c97348927
Comment 8 Fedora Update System 2017-02-17 04:18:32 EST
masscan-1.0.3-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b3f33501e7
Comment 9 Fedora Update System 2017-02-17 16:50:11 EST
masscan-1.0.3-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b3f33501e7
Comment 10 Fedora Update System 2017-02-17 17:53:34 EST
masscan-1.0.3-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c97348927
Comment 11 Fedora Update System 2017-02-25 19:20:20 EST
masscan-1.0.3-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2017-02-25 20:36:39 EST
masscan-1.0.3-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.