Bug 1307784 - mozjs38: FTBFS in rawhide
mozjs38: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mozjs38 (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Skalický
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:53 EST by Fedora Release Engineering
Modified: 2016-04-06 10:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: mozjs38-38.2.1-8.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 10:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (143.92 KB, text/plain)
2016-02-13 16:53 EST, Fedora Release Engineering
no flags Details
root.log (81.79 KB, text/plain)
2016-02-13 16:53 EST, Fedora Release Engineering
no flags Details
state.log (625 bytes, text/plain)
2016-02-13 16:53 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:53:03 EST
Your package mozjs38 failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12841554

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:53:06 EST
Created attachment 1125413 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:53:07 EST
Created attachment 1125414 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:53:09 EST
Created attachment 1125415 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:55:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Marek Skalický 2016-03-17 09:29:19 EDT
This bug is probably caused by some changes/bugs in gcc related to optimization. So it could be related to bug 1314174

Without enabled optimization mozjs38 builds fine.
Comment 6 Upstream Release Monitoring 2016-03-31 03:19:09 EDT
mskalick's mozjs38-38.2.1-8.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=750069
Comment 7 Fedora Update System 2016-03-31 04:09:14 EDT
mozjs38-38.2.1-8.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d1b18d5b4c
Comment 8 Fedora Update System 2016-04-01 16:55:22 EDT
mozjs38-38.2.1-8.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d1b18d5b4c
Comment 9 Fedora Update System 2016-04-06 10:08:25 EDT
mozjs38-38.2.1-8.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.