Bug 1307818 - openal-soft: FTBFS in rawhide
openal-soft: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openal-soft (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 16:56 EST by Fedora Release Engineering
Modified: 2016-02-20 14:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-20 14:19:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (76.07 KB, text/plain)
2016-02-13 16:56 EST, Fedora Release Engineering
no flags Details
root.log (113.25 KB, text/plain)
2016-02-13 16:56 EST, Fedora Release Engineering
no flags Details
state.log (641 bytes, text/plain)
2016-02-13 16:56 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 16:56:30 EST
Your package openal-soft failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12846438

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 16:56:32 EST
Created attachment 1125515 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 16:56:34 EST
Created attachment 1125516 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 16:56:35 EST
Created attachment 1125517 [details]
state.log
Comment 4 Hans de Goede 2016-02-20 13:39:05 EST
Hi all,

Note I'm looking into this atm (just making sure we do not do double work) seems to be arm specific ...

Regards,

Hans
Comment 5 François Cami 2016-02-20 13:52:00 EST
Hello Hans,

AFAICT yes, it's arm specific.
Marek Polacek suggested building with -mfpu=neon but I haven't gotten around to doing it yet.

François
Comment 6 Hans de Goede 2016-02-20 14:19:13 EST
Hi François,

(In reply to François Cami from comment #5)
> Hello Hans,
> 
> AFAICT yes, it's arm specific.
> Marek Polacek suggested building with -mfpu=neon but I haven't gotten around
> to doing it yet.

Building with -mfpu=neon is wrong, because we support some non neon capable SoCs with our ARM builds, so the proper fix is to tell openal-soft to not use neon. I've just fixed this for rawhide, closing.

Regards,

Hans

Note You need to log in before you can comment on or make changes to this bug.