Bug 1307871 - postbooks: FTBFS in rawhide
postbooks: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: postbooks (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Pocock
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:02 EST by Fedora Release Engineering
Modified: 2016-05-24 20:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: postbooks-4.9.5-9.fc24 postbooks-4.9.5-9.fc23 postbooks-4.9.5-9.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-24 20:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (1.83 MB, text/plain)
2016-02-13 17:02 EST, Fedora Release Engineering
no flags Details
root.log (101.84 KB, text/plain)
2016-02-13 17:02 EST, Fedora Release Engineering
no flags Details
state.log (629 bytes, text/plain)
2016-02-13 17:02 EST, Fedora Release Engineering
no flags Details
Patch to fix the FTBFS (2.11 KB, patch)
2016-03-09 12:33 EST, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:02:37 EST
Your package postbooks failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12857307

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:02:40 EST
Created attachment 1125674 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:02:41 EST
Created attachment 1125675 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:02:42 EST
Created attachment 1125676 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 09:59:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Ralf Corsepius 2016-03-09 12:33 EST
Created attachment 1134591 [details]
Patch to fix the FTBFS

This FTBFS is caused by a seemingly obvious bug in the source code, gcc-6 now treats as an error (cf. attachment).

Unless somebody objects, I will apply this patch in the attachment (against Fedora git master) and build the package in near future.
Comment 6 Daniel Pocock 2016-03-09 12:44:33 EST
Upstream has fixed this in Github and it will be in the next release.

If this is the only change required and if it matches what upstream has in Github then you are more than welcome to update the package with this patch.
Comment 7 Ralf Corsepius 2016-03-09 13:00:33 EST
(In reply to Daniel Pocock from comment #6)
> Upstream has fixed this in Github and it will be in the next release.

I can't spot any fix to this bug upstream's git.

Also, 4.9.3 is still failing with same FTBFS:
...
displays/dspBookings.cpp: In member function 'virtual void dspBookings::sViewOrder()':
displays/dspBookings.cpp:163:52: error: no matching function for call to 'salesOrder::viewSalesOrder(int, bool)'
   salesOrder::viewSalesOrder(list()->altId(), false);
...
Comment 8 Daniel Pocock 2016-03-09 13:12:09 EST
This is the message I received from upstream:

"I have seen this before. It's a bad method call that passes a boolean where a pointer is expected. It's been fixed in 4_10_x by simply removing the 2nd arg to salesOrder::viewSalesOrder() at https://github.com/xtuple/qt-client/blob/v4.9.2/guiclient/displays/dspBookings.cpp#L163"

Maybe it is in the commit from 20 May 2015:

https://github.com/xtuple/qt-client/commits/4_10_x/guiclient/displays/dspBookings.cpp
Comment 9 Gil Moskowitz 2016-03-10 15:01:33 EST
Upstream sources have been tagged v4.9.4 to address this problem: https://github.com/xtuple/qt-client/releases/tag/v4.9.4
Unlike most xTuple releases, the 4.9.4 client expects to talk to a 4.9.3 database.
Comment 10 Daniel Pocock 2016-03-10 15:41:24 EST
Gil, thanks for addressing this issue

Ralf, would you possibly have time to fetch 4.9.4 from the tag in Github and see if it builds OK?  I have more travel over the next two weeks for FOSSASIA so I didn't want to upload something today if I won't be able to respond to any other issues that arise.
Comment 11 Upstream Release Monitoring 2016-05-05 07:31:34 EDT
pocock's postbooks-4.9.5-9.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=760247
Comment 12 Fedora Update System 2016-05-06 10:44:29 EDT
postbooks-4.9.5-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f3a320414
Comment 13 Fedora Update System 2016-05-06 10:44:37 EDT
postbooks-4.9.5-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fa5678069b
Comment 14 Fedora Update System 2016-05-07 12:55:49 EDT
postbooks-4.9.5-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f3a320414
Comment 15 Fedora Update System 2016-05-07 13:26:59 EDT
postbooks-4.9.5-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fa5678069b
Comment 16 Juan Jimenez 2016-05-10 11:37:47 EDT
I can confirm that the package is installed correctly on Fedora 23 using Fedora testing repository. However, program is still unusable due to GUI glitches which hide menus and options (as per reported in bug https://www.xtuple.org/xtincident/view/bugs/27099)
Comment 17 Daniel Pocock 2016-05-11 15:41:13 EDT
Juan, thanks for the feedback.  I haven't ever seen the GUI glitches on Debian, I've asked xTuple if they can comment on why it happens on Fedora.  Is there any chance you could test the F24 update and give feedback in the xTuple bug tracker if you see the same problem?  Did you ever use the packages on F22 or other versions as well?  Please comment further in the xTuple bug tracker as this bug is only for the FTBFS issue.
Comment 18 Fedora Update System 2016-05-16 04:27:22 EDT
postbooks-4.9.5-9.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0c3e0809cd
Comment 19 Fedora Update System 2016-05-16 12:28:57 EDT
postbooks-4.9.5-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2016-05-16 18:27:09 EDT
postbooks-4.9.5-9.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2016-05-16 23:53:34 EDT
postbooks-4.9.5-9.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0c3e0809cd
Comment 22 Fedora Update System 2016-05-24 20:53:38 EDT
postbooks-4.9.5-9.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.