Bug 1307955 - python-wsme: FTBFS in rawhide
python-wsme: FTBFS in rawhide
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: python-wsme (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:11 EST by Fedora Release Engineering
Modified: 2016-02-27 12:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-27 12:59:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (89.14 KB, text/plain)
2016-02-13 17:11 EST, Fedora Release Engineering
no flags Details
root.log (83.69 KB, text/plain)
2016-02-13 17:11 EST, Fedora Release Engineering
no flags Details
state.log (637 bytes, text/plain)
2016-02-13 17:11 EST, Fedora Release Engineering
no flags Details
Patch with some debugging progress on building the package for python 3.5 (4.69 KB, patch)
2016-02-24 12:21 EST, Charalampos Stratakis
no flags Details | Diff
build log (521.80 KB, text/plain)
2016-02-24 12:23 EST, Charalampos Stratakis
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:11:03 EST
Your package python-wsme failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12863271

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:11:05 EST
Created attachment 1125926 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:11:06 EST
Created attachment 1125927 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:11:07 EST
Created attachment 1125928 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:03:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Charalampos Stratakis 2016-02-24 12:21 EST
Created attachment 1130267 [details]
Patch with some debugging progress on building the package for python 3.5

By filling some missing BuildRequires related to tests all missing module imports seem to disappear expect cherrypy and turbogear, for which some tests seem to require obsolete versions. Also used a patch to update tests source code related to sqlalchemy RelationProperty which changed to RelationshipProperty.

Build is still failing, further debugging is required.
Comment 6 Charalampos Stratakis 2016-02-24 12:23 EST
Created attachment 1130269 [details]
build log

Build log after applying patch.
Comment 7 Alan Pevec 2016-02-25 17:45:07 EST
Given upstream wsme looks abandoned, I'll propose python-wsme retirement in Fedora.
Comment 8 Fedora Admin XMLRPC Client 2016-02-27 12:56:22 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Alan Pevec 2016-02-27 12:59:26 EST
python-wsme has been retired in f24 due to py3.5 compatible and ceased upstream development.

Note You need to log in before you can comment on or make changes to this bug.