Bug 1307965 - qjson: FTBFS in rawhide
qjson: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qjson (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:12 EST by Fedora Release Engineering
Modified: 2016-02-15 10:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-14 09:16:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (123.48 KB, text/plain)
2016-02-13 17:12 EST, Fedora Release Engineering
no flags Details
root.log (105.87 KB, text/plain)
2016-02-13 17:12 EST, Fedora Release Engineering
no flags Details
state.log (697 bytes, text/plain)
2016-02-13 17:12 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:12:24 EST
Your package qjson failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12863833

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:12:27 EST
Created attachment 1125956 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:12:29 EST
Created attachment 1125957 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:12:30 EST
Created attachment 1125958 [details]
state.log
Comment 4 Rex Dieter 2016-02-14 09:16:57 EST
%changelog
* Sun Feb 14 2016 Rex Dieter <rdieter@fedoraproject.org> 0.8.1-16
- %%check: make tests non-fatal xvfb-run isn't working "cannot connect to X server" (#1307965)
Comment 5 Raphael Groner 2016-02-15 10:06:41 EST
Hmm, does xvfb-run set $DISPLAY properly?
For instance, trojita.spec can not use xvfb-run. It may need a direct call to Xvfb with a parameter for $DISPLAY, see
http://pkgs.fedoraproject.org/cgit/rpms/trojita.git/commit/?id=8a5cc9e0425bbfa9be7edfb9c27cdffaba070aaf
Comment 6 Rex Dieter 2016-02-15 10:21:46 EST
xvfb-run -a

is supposed to automatically find (and use) a free DISPLAY

In short, you're working around the fact that xvfb-run doesn't run properly either.

I guess I should file a bug
Comment 7 Rex Dieter 2016-02-15 10:45:57 EST
Heh, turns out that on my rebuild to make the check non-fatal, the xvfb-run -a call ran properly (without error)

Note You need to log in before you can comment on or make changes to this bug.