Bug 1307970 - qt5-qtwebengine: FTBFS in rawhide
qt5-qtwebengine: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt5-qtwebengine (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:12 EST by Fedora Release Engineering
Modified: 2016-02-21 21:43 EST (History)
2 users (show)

See Also:
Fixed In Version: qt5-qtwebengine-5.6.0-0.16.beta.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-21 21:43:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (120.62 KB, text/plain)
2016-02-13 17:13 EST, Fedora Release Engineering
no flags Details
state.log (685 bytes, text/plain)
2016-02-13 17:13 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:12:56 EST
Your package qt5-qtwebengine failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12864150

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:13:05 EST
Created attachment 1125971 [details]
root.log
Comment 2 Fedora Release Engineering 2016-02-13 17:13:07 EST
Created attachment 1125972 [details]
state.log
Comment 3 Kevin Kofler 2016-02-14 17:50:58 EST
This failed due to a GCC bug:

/builddir/build/BUILD/qtwebengine-opensource-src-5.6.0-beta/src/3rdparty/chromium/third_party/WebKit/Source/web/WebPageSerializerImpl.cpp: In member function 'WTF::String blink::WebPageSerializerImpl::preActionBeforeSerializeEndTag(const blink::Element*, blink::WebPageSerializerImpl::SerializeDomParam*, bool*)':
/builddir/build/BUILD/qtwebengine-opensource-src-5.6.0-beta/src/3rdparty/chromium/third_party/WebKit/Source/web/WebPageSerializerImpl.cpp:220:8: internal compiler error: in assign_temp, at function.c:961
 String WebPageSerializerImpl::preActionBeforeSerializeEndTag(
        ^~~~~~~~~~~~~~~~~~~~~

which should be fixed by now. I resubmitted the build.
Comment 4 Kevin Kofler 2016-02-14 19:01:07 EST
Looks like we're hitting yet another GCC bug now (the same that's also breaking kdelibs3):

/builddir/build/BUILD/qtwebengine-opensource-src-5.6.0-beta/src/3rdparty/chromium/ppapi/shared_impl/private/net_address_private_impl.cc:414:6: error: prototype for 'bool ppapi::NetAddressPrivateImpl::SockaddrToNetAddress(const sockaddr*, uint32_t, PP_NetAddress_Private*)' does not match any in class 'ppapi::NetAddressPrivateImpl'
 bool NetAddressPrivateImpl::SockaddrToNetAddress(
      ^~~~~~~~~~~~~~~~~~~~~
In file included from /builddir/build/BUILD/qtwebengine-opensource-src-5.6.0-beta/src/3rdparty/chromium/ppapi/shared_impl/private/net_address_private_impl.cc:5:0:
/builddir/build/BUILD/qtwebengine-opensource-src-5.6.0-beta/src/3rdparty/chromium/ppapi/shared_impl/private/net_address_private_impl.h:25:15: error: candidate is: static bool ppapi::NetAddressPrivateImpl::SockaddrToNetAddress(const sockaddr*, uint32_t, PP_NetAddress_Private*)
   static bool SockaddrToNetAddress(const sockaddr* sa,
               ^~~~~~~~~~~~~~~~~~~~
Comment 5 Kevin Kofler 2016-02-21 21:43:19 EST
Looks like http://koji.fedoraproject.org/koji/taskinfo?taskID=13085760 is building now (pending ARM as usual), the GCC issues seem finally addressed.

Note You need to log in before you can comment on or make changes to this bug.