Bug 1307992 - rhdb-utils: FTBFS in rawhide
rhdb-utils: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhdb-utils (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
: 1424261 (view as bug list)
Depends On: 784281
Blocks: F24FTBFS F26FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:15 EST by Fedora Release Engineering
Modified: 2017-02-20 11:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-20 11:43:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (4.75 KB, text/plain)
2016-02-13 17:15 EST, Fedora Release Engineering
no flags Details
root.log (80.81 KB, text/plain)
2016-02-13 17:15 EST, Fedora Release Engineering
no flags Details
state.log (633 bytes, text/plain)
2016-02-13 17:15 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:15:33 EST
Your package rhdb-utils failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12864972

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:15:37 EST
Created attachment 1126036 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:15:39 EST
Created attachment 1126037 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:15:42 EST
Created attachment 1126038 [details]
state.log
Comment 4 Pavel Raiskup 2016-02-15 05:21:48 EST
commit c619c2351f7ec429b6ddce519c939f7b8465d711
Author:     Heikki Linnakangas <heikki.linnakangas@iki.fi>
AuthorDate: Mon Feb 9 11:17:56 2015 +0200
Commit:     Heikki Linnakangas <heikki.linnakangas@iki.fi>
CommitDate: Mon Feb 9 11:17:56 2015 +0200

    Move pg_crc.c to src/common, and remove pg_crc_tables.h
    
    To get CRC functionality in a client program, you now need to link with
    libpgcommon instead of libpgport. The CRC code has nothing to do with
    portability, so libpgcommon is a better home. (libpgcommon didn't exist
    when pg_crc.c was originally moved to src/port.)
    
    Remove the possibility to get CRC functionality by just #including
    pg_crc_tables.h. I'm not aware of any extensions that actually did that and
    couldn't simply link with libpgcommon.
    
    This also moves the pg_crc.h header file from src/include/utils to
    src/include/common, which will require changes to any external programs
    that currently does #include "utils/pg_crc.h". That seems acceptable, as
    include/common is clearly the right home for it now, and the change needed
    to any such programs is trivial.


Seems like we need to have bug #784281 resolved first.
Comment 5 Jan Kurik 2016-02-24 10:05:44 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Pavel Raiskup 2016-02-26 04:41:55 EST
Upstream thread:
http://www.postgresql.org/message-id/55C5EA3E.9050509@uptime.jp
Comment 7 Pavel Raiskup 2017-02-20 11:05:36 EST
*** Bug 1424261 has been marked as a duplicate of this bug. ***
Comment 8 Pavel Raiskup 2017-02-20 11:43:42 EST
F26 commit:
77b8fff52e14c6397191999dd0a82d32e9499f50

Thanks for new upstream release!

Note You need to log in before you can comment on or make changes to this bug.