Bug 13080 - Changes to Del and BkSpc
Summary: Changes to Del and BkSpc
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-26 21:06 UTC by steve
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 17:48:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description steve 2000-06-26 21:06:17 UTC
Xterms initiated external to our servers running RedHat 6.2 no longer
respond to BkSpc and Del keypresses. The symbols returned by these keys
used to be "^?" and "^H" and have changed such that both now return "~[[3"
which is unrecognized by Exceed or any other X emulation program we have
tried. The fact that this issue is not isolated to any one particular
emulator and appeared immediately following our 6.2 install indicates this
is an issue to be resolved by RedHat. Terminals running directly on the
console work without issue.

  Since our installation of 6.2, remotely displayed xterms do not function
correctly. I realize that this has been reported as a bug before; however
satisfactory explanation is yet to be given for resolving this problem.
Just saying "We've gone to Debian keymapping" or "Modify
/usr/lib/X11/app-defaults/XTerm" is not sufficient.

  Simply put, the functionality of widely used, existing and correctly
functioning applications have suddenly stopped working due to external
changes, namely an OS upgrade. These changes have occurred without
installation note warnings or instructions regarding how to resolve
problems from either the client or the server side. Please either post a
downloadable fix or put some sort of detailed instructions for resolving
issues related to RedHat's change from previously implemented and widely
accepted practices on the RedHat site at an easily accessed location.

Steve

Comment 1 Bernd Wiebelt 2000-07-20 13:46:35 UTC
Changes to /usr/lib/X11/app-defaults/XTerm that worked for me
[XWin-32 connecting to Linux running xdm]:

1. Removed the whole Intellimouse section.
   --> Backspace key is back

2. added
   *sunKeyboard: true
   --> delete works again under pine

works for me ;-)

Comment 2 Mike A. Harris 2000-11-25 08:54:02 UTC
I am unable to reproduce the situation that you describe.  I do not have
access to the commercial applications listed to test them, however I've
used both Red Hat 6.2 and 7.0 and it works fine for me.



Note You need to log in before you can comment on or make changes to this bug.