Bug 1308003 - rubygem-ammeter: FTBFS in rawhide
rubygem-ammeter: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-ammeter (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:16 EST by Fedora Release Engineering
Modified: 2016-04-07 08:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: rubygem-ammeter-1.1.3-1.fc25 rubygem-ammeter-1.1.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 08:07:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (19.32 KB, text/plain)
2016-02-13 17:16 EST, Fedora Release Engineering
no flags Details
root.log (88.72 KB, text/plain)
2016-02-13 17:16 EST, Fedora Release Engineering
no flags Details
state.log (653 bytes, text/plain)
2016-02-13 17:17 EST, Fedora Release Engineering
no flags Details
Update to v1.1.3. Fix test suite for Ruby 2.3 compatibility. (1.79 KB, patch)
2016-03-29 11:44 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:16:53 EST
Your package rubygem-ammeter failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12865597

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:16:55 EST
Created attachment 1126069 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:16:57 EST
Created attachment 1126070 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:17:02 EST
Created attachment 1126071 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:06:32 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Jun Aruga 2016-03-29 11:44 EDT
Created attachment 1141328 [details]
Update to v1.1.3. Fix test suite for Ruby 2.3 compatibility.

I updated rpm spec file to fix test suite for Ruby 2.3.

*The reason of the test failure
 
File#read is re-defined in spec/spec_helpr.rb#stub_file,
and File#read is also used in 'require': specification.rb#load.
If the first "require" for on library is called after the stub definition,
it is failed.

On upstream, its test was succeeded.
Though I am not sure its reason clearly, when I did run "rspec spec/" by ruby 2.2.4p230, putting debuglog in kernel_require.rb#require, "rubygems/requirement" was called from somewhere, and 'haml' was called, before rspec and the stub definition were run.

But On mock environment, its "rubygems/requirement" was not called. And a "require" after the stub definition, causes the error.

So, I did put "require haml" as a rspec argument.

Also updated to ammeter latest version as I supposed it might fix this issue, but actually the result was same.


*Lint result
2 errors about the shebang.
rubygem-ammeter-doc.noarch: E: non-executable-script /usr/share/gems/gems/ammeter-1.1.3/features/templates/my_rails_gem/Rakefile 644 /usr/bin/env
rubygem-ammeter-doc.noarch: E: non-executable-script /usr/share/gems/gems/ammeter-1.1.3/features/templates/my_railties_gem/Rakefile 644 /usr/bin/env

Its Rakefile are used as a template.
So, I though I could not modify this for the compatibility of original gem.
But I did pull-request for issue, to fix this for next version.
https://github.com/alexrothenberg/ammeter/pull/52


*Dependency of ammeter.

1) Runtime dependencies:
$ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(ammeter)'
  => no result.
$ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-ammeter'
rubygem-ammeter-doc-0:1.1.2-2.fc23.noarch

2) As well as development dependencies:
$ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem(ammeter)'
rubygem-cucumber-rails-0:1.4.2-1.fc24.src
  => gemspec file OK.
     https://rubygems.org/gems/cucumber-rails/versions/1.4.2

rubygem-rspec-rails-0:3.3.3-1.fc24.src
  => ammeter is specified as a 1.1.2 in gemspec file.
  https://rubygems.org/gems/rspec-rails/versions/3.3.3

  As the test of rspec-rails was passed with latest ammter versoin 1.1.3, I sent pull-request.
  https://github.com/rspec/rspec-rails/pull/1592
  Also rspec-rails rpm spec file is ok.
    
$ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem-ammeter'
  => no result
Comment 6 Upstream Release Monitoring 2016-03-30 06:34:30 EDT
jaruga's rubygem-ammeter-1.1.3-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=749895
Comment 7 Fedora Update System 2016-03-30 08:00:51 EDT
rubygem-ammeter-1.1.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6902a0f26
Comment 8 Fedora Update System 2016-03-30 18:25:40 EDT
rubygem-ammeter-1.1.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6902a0f26
Comment 9 Fedora Update System 2016-04-07 08:07:25 EDT
rubygem-ammeter-1.1.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.