Bug 1308004 - rubygem-ancestry: FTBFS in rawhide
rubygem-ancestry: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-ancestry (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:17 EST by Fedora Release Engineering
Modified: 2016-04-07 08:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: rubygem-ancestry-2.1.0-4.fc25 rubygem-ancestry-2.1.0-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 08:07:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (8.68 KB, text/plain)
2016-02-13 17:17 EST, Fedora Release Engineering
no flags Details
root.log (84.17 KB, text/plain)
2016-02-13 17:17 EST, Fedora Release Engineering
no flags Details
state.log (657 bytes, text/plain)
2016-02-13 17:17 EST, Fedora Release Engineering
no flags Details
Fix test suite for Ruby 2.3 compatibility. (4.65 KB, patch)
2016-03-31 05:51 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:17:03 EST
Your package rubygem-ancestry failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12865602

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:17:05 EST
Created attachment 1126072 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:17:06 EST
Created attachment 1126073 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:17:08 EST
Created attachment 1126074 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:06:35 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Jun Aruga 2016-03-31 05:51 EDT
Created attachment 1142135 [details]
Fix test suite for Ruby 2.3 compatibility.

Hi,

I fixed the test suite for Ruby 2.3.
Could you check my attachment file?

As a note, I used patch command instead of %patch macro, because the patch is to replace a test file only, I wanted to use patch in %check section. %patch macro looks available for only %prep section.

Issue is here.
https://github.com/stefankroes/ancestry/issues/237
and fixed commit hash is 2d78eac7bf5e756f817fae9c9f8fec1071004c27

because I fixed the error of rpmlint, I deleted the line: Provides: rubygem(%{gem_name}) = %{version}
Comment 6 Upstream Release Monitoring 2016-04-01 07:15:27 EDT
jaruga's rubygem-ancestry-2.1.0-4.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=750343
Comment 7 Fedora Update System 2016-04-01 07:58:39 EDT
rubygem-ancestry-2.1.0-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-666ca5af98
Comment 8 Fedora Update System 2016-04-02 01:24:45 EDT
rubygem-ancestry-2.1.0-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-666ca5af98
Comment 9 Fedora Update System 2016-04-07 08:07:04 EDT
rubygem-ancestry-2.1.0-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.