Bug 1308020 - rubygem-database_cleaner: FTBFS in rawhide
rubygem-database_cleaner: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rubygem-database_cleaner (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vít Ondruch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:18 EST by Fedora Release Engineering
Modified: 2016-07-25 08:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: rubygem-database_cleaner-1.5.3-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-25 08:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (34.37 KB, text/plain)
2016-02-13 17:18 EST, Fedora Release Engineering
no flags Details
root.log (92.95 KB, text/plain)
2016-02-13 17:18 EST, Fedora Release Engineering
no flags Details
state.log (689 bytes, text/plain)
2016-02-13 17:18 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:18:44 EST
Your package rubygem-database_cleaner failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12865950

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:18:47 EST
Created attachment 1126120 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:18:48 EST
Created attachment 1126121 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:18:50 EST
Created attachment 1126122 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:07:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Jun Aruga 2016-05-02 10:12:14 EDT
Though this is just memo, I tried to test latest version 1.5.3 in my mock environment. But test was failed for some reason related on rubygem-mongo.
So, I will check rubygem-mongo later.

Failures:
  1) DatabaseCleaner::Mongo::Truncation truncates all collections by default
     Failure/Error: model_class.count.should equal(expected_count), "#{model_class} expected to have a count of #{expected_count} but was #{model_class.count}"
       MongoTest::Widget expected to have a count of 0 but was 1
     # ./spec/database_cleaner/mongo/truncation_spec.rb:27:in `block in ensure_counts'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:26:in `each'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:26:in `ensure_counts'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:44:in `block (2 levels) in <module:Mongo>'
  2) DatabaseCleaner::Mongo::Truncation when collections are provided to the :only option only truncates the specified collections
     Failure/Error: model_class.count.should equal(expected_count), "#{model_class} expected to have a count of #{expected_count} but was #{model_class.count}"
       MongoTest::Widget expected to have a count of 0 but was 1
     # ./spec/database_cleaner/mongo/truncation_spec.rb:27:in `block in ensure_counts'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:26:in `each'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:26:in `ensure_counts'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:54:in `block (3 levels) in <module:Mongo>'
  3) DatabaseCleaner::Mongo::Truncation when collections are provided to the :except option truncates all but the specified collections
     Failure/Error: model_class.count.should equal(expected_count), "#{model_class} expected to have a count of #{expected_count} but was #{model_class.count}"
       MongoTest::Gadget expected to have a count of 0 but was 1
     # ./spec/database_cleaner/mongo/truncation_spec.rb:27:in `block in ensure_counts'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:26:in `each'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:26:in `ensure_counts'
     # ./spec/database_cleaner/mongo/truncation_spec.rb:65:in `block (3 levels) in <module:Mongo>'
Comment 6 Vít Ondruch 2016-05-02 10:22:30 EDT
(In reply to Jun Aruga from comment #5)
> Though this is just memo, I tried to test latest version 1.5.3 in my mock
> environment. But test was failed for some reason related on rubygem-mongo.


Have seen something like this?

http://koji.fedoraproject.org/koji/taskinfo?taskID=13603076


As far as I remember, similar issues started since GCC 6.x landed in Rawhide. You might want to check with MongoDB maintainer (although they have not appeared in Koschei since mongodb-3.2.4-1.fc25 was released) ....
Comment 7 Upstream Release Monitoring 2016-07-25 08:53:25 EDT
vondruch's rubygem-database_cleaner-1.5.3-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=785329
Comment 8 Vít Ondruch 2016-07-25 08:58:48 EDT
I disabled the tests. It seems to be some incompatibility of MongoDB 3.x or what not ... May be we need to update rubygem-mongo, but this update is blocked by DNF ...

Note You need to log in before you can comment on or make changes to this bug.