Bug 130804 - XChat default download directory should be ~/Desktop/Downloads
Summary: XChat default download directory should be ~/Desktop/Downloads
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Reed
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-24 20:14 UTC by Bryan W Clark
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-06 18:14:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan W Clark 2004-08-24 20:14:29 UTC
The current default download directory for XChat is
~/.xchat/downloads/ which [in terms of our user experience] is
crap(tm) :-)  

To keep things centralized it'd be nice if XChat used the GConf key
that we have for Epiphany downloads directory
(/apps/epiphany/directories/downloads_folder), of course since XChat
doesn't use GConf we can't keep up with a the user possibly changing
the directory.  

For now lets change the default download directory to
~/Desktop/Downloads [which is Epiphany's default] so we will at least
keep things a little more sane for first time installs that use XChat
for some reason.  Hopefully XChat will try to start using GConf in the
future although this is not likely I suppose.

Comment 2 Bryan W Clark 2004-10-15 06:28:12 UTC
reopening since i believe that closing upstream means more that the
problem is being handled upstream, not just that a bug has been filed
and the problem isn't getting fixed.  This isn't a high priority bug,
but if upstream isn't interested in the user experience it's our job
to patch or find new software that is.

Comment 3 Daniel Reed 2004-11-06 18:14:51 UTC
The problem is being addressed upstream, though it appears to have stagnated due
to lack of input. From the upstream bug:
-----------------------------------------------------
Date: 2004-08-27 05:36
Sender: ckorff
Logged In: YES 
user_id=69287

different people, different desktops - Support for one speciefied
Desktop
should be done by the distribution.
Nobody needs a additional dependency (GConf)
However, this is only my opinion as xchat user.
-----------------------------------------------------
Date: 2004-09-20 06:30
Sender: zed
Logged In: YES 
user_id=5012

Does ~/Desktop work on KDE too?
-----------------------------------------------------

Please follow up using the upstream bug.


Note You need to log in before you can comment on or make changes to this bug.