Bug 1308046 - rubygem-listen: FTBFS in rawhide
rubygem-listen: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-listen (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:21 EST by Fedora Release Engineering
Modified: 2016-05-07 08:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: rubygem-listen-3.0.6-1.fc25 rubygem-listen-3.0.6-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-07 08:00:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (14.38 KB, text/plain)
2016-02-13 17:21 EST, Fedora Release Engineering
no flags Details
root.log (85.12 KB, text/plain)
2016-02-13 17:21 EST, Fedora Release Engineering
no flags Details
state.log (649 bytes, text/plain)
2016-02-13 17:21 EST, Fedora Release Engineering
no flags Details
Update-to-3.0.6 to fix test suite for Ruby 2.3 compatibility (4.58 KB, patch)
2016-04-20 10:44 EDT, Jun Aruga
no flags Details | Diff
version 3.0.6 test files (21.12 KB, application/x-gzip)
2016-04-20 10:45 EDT, Jun Aruga
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:21:16 EST
Your package rubygem-listen failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12866597

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:21:19 EST
Created attachment 1126198 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:21:21 EST
Created attachment 1126199 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:21:22 EST
Created attachment 1126200 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:08:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Jun Aruga 2016-04-20 10:22:15 EDT
I will fix this!
Comment 6 Jun Aruga 2016-04-20 10:44 EDT
Created attachment 1149114 [details]
Update-to-3.0.6 to fix test suite for Ruby 2.3 compatibility

*Highlight*
I updated to version 3.0.6 to fix test suite for Ruby 2.3 compatibility.
And I will upload rubygem-listen-3.0.6-tests.tgz that is test code for version 3.0.6 later.

I changed the logic to remove the hard coded dependencies from the patch file to the replacement with "sed" command. This new logic, do not need to update the patch file after updating the package version. It looks better.


*Package Dependencies*

I checked the impact for the dependency rubygem-listen v3.0.6.
f23 is not target in this time.

+ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(listen)'
rubygem-rerun-0:0.10.0-3.fc23.noarch
rubygem-rerun-0:0.10.0-4.fc24.noarch
  => rpm spec file: ok
  => gem spec file: https://rubygems.org/gems/rerun/versions/0.10.0
  => this is working with rubygem-listen >= 3.0 by the patch.
rubygem-sass-0:3.4.4-2.fc23.noarch
vagrant-0:1.7.4-1.fc23.noarch
vagrant-0:1.8.1-1.fc23.noarch
vagrant-0:1.8.1-1.fc24.noarch
  Requires: rubygem(listen) >= 3.0.2
  Requires: rubygem(listen) < 3.1 
    => ok

+ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-listen'
rubygem-listen-doc-0:3.0.3-1.fc23.noarch
rubygem-listen-doc-0:3.0.3-1.fc24.noarch
  => ok

+ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem(listen)'
rubygem-rerun-0:0.10.0-4.fc24.src
vagrant-0:1.8.1-1.fc24.src
  => ok

+ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem-listen'
  => No result
Comment 7 Jun Aruga 2016-04-20 10:45 EDT
Created attachment 1149115 [details]
version 3.0.6 test files
Comment 8 Vít Ondruch 2016-04-21 01:42:55 EDT
(In reply to Jun Aruga from comment #5)
> I will fix this!

Thx. I approved you in PkgDB



(In reply to Jun Aruga from comment #6)
> Created attachment 1149114 [details]
> Update-to-3.0.6 to fix test suite for Ruby 2.3 compatibility
> 
> *Highlight*
> I updated to version 3.0.6 to fix test suite for Ruby 2.3 compatibility.
> And I will upload rubygem-listen-3.0.6-tests.tgz that is test code for
> version 3.0.6 later.
> 
> I changed the logic to remove the hard coded dependencies from the patch
> file to the replacement with "sed" command. This new logic, do not need to
> update the patch file after updating the package version. It looks better.

Of course this has bright sides (you don't need to update the patch when new version is release) and it has downsides (you don't have to check what was actually changed, if there are introduced new dependencies or removed the old ones, since the "sed" always works, hence some unexpected dependencies can sneak in). So to say, I'm fine with that change, just wanted to highlight possible impacts.

BTW you might consider to use this sed commands similar to this instead:

  sed -i -e '/^.*<rb-fsevent>.*$/ s/^/#/' ./listen-%{version}.gemspec

which just comments out the lines. Also, I am not sure if the /g in the pattern of your sed is really needed ...
Comment 9 Upstream Release Monitoring 2016-04-21 04:34:40 EDT
jaruga's rubygem-listen-3.0.6-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=756501
Comment 10 Jun Aruga 2016-04-21 05:22:12 EDT
Hi, Vit. 
Thanks for your review, and for the information of the possible impacts.

I used your way.
> sed -i -e '/^.*<rb-fsevent>.*$/ s/^/#/' ./listen-%{version}.gemspec

Actually I could replace multiplex target lines without "/g".
I did not need to use "/g" in this case. [1]

[1]
https://www.gnu.org/software/sed/manual/sed.html#The-_0022s_0022-Command
> g: Apply the replacement to all matches to the regexp, not just the first
Comment 11 Fedora Update System 2016-04-21 06:30:16 EDT
rubygem-listen-3.0.6-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d04e36fa8d
Comment 12 Fedora Update System 2016-04-21 17:56:13 EDT
rubygem-listen-3.0.6-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d04e36fa8d
Comment 13 Fedora Update System 2016-05-07 08:00:26 EDT
rubygem-listen-3.0.6-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.