Bug 1308069 - rubygem-rack: FTBFS in rawhide
rubygem-rack: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-rack (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:23 EST by Fedora Release Engineering
Modified: 2016-05-07 07:41 EDT (History)
7 users (show)

See Also:
Fixed In Version: rubygem-rack-1.6.4-1.fc25 rubygem-rack-1.6.4-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-07 07:41:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (85.96 KB, text/plain)
2016-02-13 17:23 EST, Fedora Release Engineering
no flags Details
root.log (84.71 KB, text/plain)
2016-02-13 17:23 EST, Fedora Release Engineering
no flags Details
state.log (641 bytes, text/plain)
2016-02-13 17:23 EST, Fedora Release Engineering
no flags Details
Update to 1.6.4. Fix test suite for FTBFS. (1.83 KB, patch)
2016-05-02 08:46 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:23:18 EST
Your package rubygem-rack failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12867034

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:23:21 EST
Created attachment 1126268 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:23:24 EST
Created attachment 1126269 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:23:26 EST
Created attachment 1126270 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:09:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Jun Aruga 2016-04-21 08:24:49 EDT
Hi, I checked this FTBFS issue.

Seeing koschei build histories,
resent 4 times the builds were succeeded. (2016-04-14 - 2016-04-21)
and those were failed past 3 times (2016-04-08 - 2016-04-12).
[1]

The error in the 3 times was same.

https://kojipkgs.fedoraproject.org/work/tasks/8739/13638739/build.log
+ bacon -Ilib --automatic --quiet
/builddir/build/BUILD/rubygem-rack-1.6.2/usr/share/gems/gems/rack-1.6.2/lib/rack/cascade.rb:7:in `<class:Cascade>': uninitialized constant Rack::Cascade::CONTENT_TYPE (NameError)
	from /builddir/build/BUILD/rubygem-rack-1.6.2/usr/share/gems/gems/rack-1.6.2/lib/rack/cascade.rb:6:in `<module:Rack>'
	from /builddir/build/BUILD/rubygem-rack-1.6.2/usr/share/gems/gems/rack-1.6.2/lib/rack/cascade.rb:1:in `<top (required)>'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
	from test/spec_cascade.rb:1:in `<top (required)>'
	from /usr/share/gems/gems/bacon-1.2.0/bin/bacon:116:in `load'
	from /usr/share/gems/gems/bacon-1.2.0/bin/bacon:116:in `block in <top (required)>'
	from /usr/share/gems/gems/bacon-1.2.0/bin/bacon:115:in `each'
	from /usr/share/gems/gems/bacon-1.2.0/bin/bacon:115:in `<top (required)>'
	from /usr/bin/bacon:23:in `load'
	from /usr/bin/bacon:23:in `<main>'

So, If the error will happened in the future again, we can check "bacon" with --debug or without --quiet option.

I have checked it in local mock environment now, but those were succeeded 10 times. Still no error in my mock environment.

[1] https://apps.fedoraproject.org/koschei/package/rubygem-rack
Comment 6 Vít Ondruch 2016-04-29 10:01:34 EDT
I'd say that it depends on the order of the execution. You might try to run test/spec_cascade.rb independently of the rest of the test suite and the issue might demonstrate itself. Also, there is 1.6.4 already so you might want to check the 1.6.4.
Comment 7 Jun Aruga 2016-04-29 10:50:41 EDT
Vit. I will try it. Thanks.
Comment 8 Jun Aruga 2016-05-02 07:24:45 EDT
I understood the reason of the error.

The test was failed for below test file.
And I found the patch at upstream master branch to fix it, though it is not updated to latest version.
So, I will update rack to the latest stable version and run the patch for that.

$ bacon -Ilib --automatic test/spec_cascade.rb
Comment 9 Jun Aruga 2016-05-02 08:46 EDT
Created attachment 1152947 [details]
Update to 1.6.4. Fix test suite for FTBFS.

I updated to 1.6.4.
And I fixed a test suite failure.

If lib/rack.rb is not called before test/spec_cascade.rb is called, the spec_cascade.rb is failed.

Though rpmlint warned below things,
> rubygem-rack-doc.noarch: E: wrong-script-interpreter /usr/share/gems/gems/rack-1.6.4/test/cgi/test.ru ../../bin/rackup
https://github.com/rack/rack/blob/1.6.4/test/cgi/test.ru#L1

I ignored this as it looks correct, and remaining from last time.

Could you check my patch?
Thanks.
Comment 10 Vít Ondruch 2016-05-02 09:53:53 EDT
(In reply to Jun Aruga from comment #9)
> Created attachment 1152947 [details]
> Update to 1.6.4. Fix test suite for FTBFS.

I would change the version in patch name, IOW the patch should be named:

rubygem-rack-2.0.0.alpha-fix-test.patch

since the patch was release just as part of 2.0.0.alpha version, not the 1.6.4.




> Though rpmlint warned below things,
> > rubygem-rack-doc.noarch: E: wrong-script-interpreter /usr/share/gems/gems/rack-1.6.4/test/cgi/test.ru ../../bin/rackup
> https://github.com/rack/rack/blob/1.6.4/test/cgi/test.ru#L1
> 
> I ignored this as it looks correct, and remaining from last time.

Yes, this a bit unfortunate, but should have no influence on anything as far as I can tell.


Also, the .spec file would deserve some cleanup. For example, I would remove all references to %{?fc20} since this version of Fedora is not supported anymore. But these are just minor nits.

Feel free to submit the update (I approved you in pkgdb).
Comment 11 Upstream Release Monitoring 2016-05-02 10:36:53 EDT
jaruga's rubygem-rack-1.6.4-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=759501
Comment 12 Fedora Update System 2016-05-02 10:54:11 EDT
rubygem-rack-1.6.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a10387a84c
Comment 13 Jun Aruga 2016-05-02 10:59:39 EDT
Vit, thanks for the reviewing.
I submitted the update right now.
So, you can rename the patch, and modify the spec file.
Comment 14 Fedora Update System 2016-05-03 07:23:30 EDT
rubygem-rack-1.6.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a10387a84c
Comment 15 Fedora Update System 2016-05-07 07:41:18 EDT
rubygem-rack-1.6.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.