Bug 1308082 - rubygem-sass: FTBFS in rawhide
rubygem-sass: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-sass (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:24 EST by Fedora Release Engineering
Modified: 2016-05-07 07:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: rubygem-sass-3.4.22-1.fc25 rubygem-sass-3.4.22-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-07 07:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (45.60 KB, text/plain)
2016-02-13 17:24 EST, Fedora Release Engineering
no flags Details
root.log (83.06 KB, text/plain)
2016-02-13 17:24 EST, Fedora Release Engineering
no flags Details
state.log (645 bytes, text/plain)
2016-02-13 17:24 EST, Fedora Release Engineering
no flags Details
Fix test suite for Ruby 2.3 compatibility (1.38 KB, patch)
2016-04-26 11:59 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:24:28 EST
Your package rubygem-sass failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12867409

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:24:31 EST
Created attachment 1126307 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:24:33 EST
Created attachment 1126308 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:24:34 EST
Created attachment 1126309 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:10:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Jun Aruga 2016-04-26 11:01:31 EDT
I will fix this!
Comment 6 Jun Aruga 2016-04-26 11:59 EDT
Created attachment 1151002 [details]
Fix test suite for Ruby 2.3 compatibility

I update to 3.4.22 to fix test suite for Ruby 2.3.

*highlight*
The reason that the test suite was failed is that the error message of ArgumentError class has been changed at Ruby 2.3. The sass is parsing the message. and it is fixed by updating the sass version.

I changed %files section because I ran gem2rpm, and compared the created spec file, and current spec file. It looks simpler.

*dependency*
All related packages are ok. [1]

Could you merge my attachment patch file?
Thanks.



[1] How to check dependency.
fc24, fc25 are target.

+ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(sass)'
openqa-0:4.3-22.fc23.noarch
openqa-0:4.3-24.20160408git45e4923.fc25.noarch
  => rpm spec: ok
rubygem-bootstrap-sass-0:2.3.2.2-4.fc23.noarch
rubygem-bootstrap-sass-0:2.3.2.2-5.fc24.noarch
  => rpm spec: ok
  => gem spec: ok
    https://rubygems.org/gems/bootstrap-sass/versions/2.3.2.2
rubygem-compass-0:1.0.1-3.fc23.noarch
rubygem-compass-0:1.0.1-3.fc24.noarch
  => gem spec: ok
    https://rubygems.org/gems/compass/versions/1.0.1

rubygem-compass-core-0:1.0.1-5.fc23.noarch
rubygem-compass-core-0:1.0.1-6.fc24.noarch
  => rpm spec: ok
  => gem spec: ok
    https://rubygems.org/gems/compass-core/versions/1.0.1

rubygem-compass-import-once-0:1.0.5-5.fc23.noarch
rubygem-compass-import-once-0:1.0.5-6.fc24.noarch
  => rpm spec: ok
  => gem spec: ok
    https://rubygems.org/gems/compass-import-once/versions/1.0.5
rubygem-haml-0:4.0.5-4.fc21.noarch
rubygem-sass-rails-0:5.0.3-2.fc23.noarch
rubygem-sass-rails-0:5.0.4-2.fc24.noarch
  => rpm spec: ok
  => gem spec: ok
    https://rubygems.org/gems/sass-rails/versions/5.0.4
rubygem-sass-twitter-bootstrap-0:2.3.0-3.fc23.noarch
rubygem-sass-twitter-bootstrap-0:2.3.0-4.fc24.noarch
  => rpm spec: ok
  => gem spec: ok
    https://rubygems.org/gems/sass-rails/versions/5.0.4
rubygem-sass-twitter-bootstrap-0:2.3.0-3.fc23.noarch
rubygem-sass-twitter-bootstrap-0:2.3.0-4.fc24.noarch
  => rpm spec: ok
  => gem spec: ok
    https://rubygems.org/gems/sass-twitter-bootstrap/versions/2.3.0

+ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-sass'
Last metadata expiration check: 0:00:04 ago on Tue Apr 26 17:04:00 2016.
gnome-code-assistance-0:3.16.0-3.fc23.x86_64
gnome-code-assistance-0:3.16.0-6.fc25.x86_64
  => rpm spec: ok
rubygem-sass-doc-0:3.4.19-1.fc24.noarch
  => ok
rubygem-sass-doc-0:3.4.4-2.fc23.noarch

+ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem(sass)'
Fedora - Rawhide - Source               7.8 MB/s | 6.4 MB     00:00----
Last metadata expiration check: 0:00:01 ago on Tue Apr 26 17:04:12 2016.
php-Assetic-0:1.3.2-3.fc25.src
  => rpm spec: ok
rubygem-bootstrap-sass-0:2.3.2.2-5.fc24.src
  => ok
rubygem-compass-core-0:1.0.1-6.fc24.src
  => ok
rubygem-compass-import-once-0:1.0.5-6.fc24.src
  => ok
rubygem-haml-0:4.0.5-4.fc21.src
rubygem-sass-rails-0:5.0.4-2.fc24.src
  => ok
rubygem-slim-0:2.0.2-1.fc21.src
rubygem-sprockets-0:3.2.0-3.fc24.src
  => rpm spec: ok
  => gem spec: ok
    https://rubygems.org/gems/sprockets/versions/3.2.0
rubygem-tilt-0:2.0.1-2.fc24.src
  => rpm spec: ok
  => gem spec: ok

+ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem-sass'
gnome-code-assistance-0:3.16.0-6.fc25.src
  => ok
Comment 7 Jun Aruga 2016-04-28 04:13:37 EDT
Hello, package owners (lkundrak, mmorsi).

Could you check above my patch file to fix Ruby 2.3 compatibility?
I also requested Commit ACLs at PkgDB [1], as I can commit it by myself.
[1] https://admin.fedoraproject.org/pkgdb/package/rpms/rubygem-sass/
Comment 8 Vít Ondruch 2016-04-29 11:02:06 EDT
Hi Jun,

Thanks for the patch. I approved your ACL in pkgdb, so feel free to submit update. BTW don't forget to resolve the bug 1290624 as well once you fix this.
Comment 9 Upstream Release Monitoring 2016-05-02 04:13:49 EDT
jaruga's rubygem-sass-3.4.22-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=759262
Comment 10 Fedora Update System 2016-05-02 04:35:50 EDT
rubygem-sass-3.4.22-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-198f0a44cd
Comment 11 Fedora Update System 2016-05-02 06:52:55 EDT
rubygem-sass-3.4.22-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-198f0a44cd
Comment 12 Fedora Update System 2016-05-07 07:43:19 EDT
rubygem-sass-3.4.22-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.