Bug 1308094 - rubygem-typhoeus: FTBFS in rawhide
rubygem-typhoeus: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-typhoeus (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:25 EST by Fedora Release Engineering
Modified: 2016-05-27 23:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: rubygem-typhoeus-1.0.2-1.fc25 rubygem-typhoeus-1.0.2-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-27 23:35:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (75.82 KB, text/plain)
2016-02-13 17:25 EST, Fedora Release Engineering
no flags Details
root.log (85.19 KB, text/plain)
2016-02-13 17:25 EST, Fedora Release Engineering
no flags Details
state.log (657 bytes, text/plain)
2016-02-13 17:25 EST, Fedora Release Engineering
no flags Details
Update to v1.0.2 to fix test suite for Ruby 2.3.0 compatibility (1.48 KB, patch)
2016-05-17 06:40 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:25:36 EST
Your package rubygem-typhoeus failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12867717

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:25:39 EST
Created attachment 1126343 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:25:40 EST
Created attachment 1126344 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:25:41 EST
Created attachment 1126345 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:11:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Vít Ondruch 2016-05-02 06:56:30 EDT
Interesting, this seem to be fixed by Ruby 2.3.1.

@Jun, could you please investigate this?
Comment 6 Jun Aruga 2016-05-02 07:05:59 EDT
Vit, yes I will investigate this later.
Comment 7 Jun Aruga 2016-05-17 06:16:11 EDT
Let me fix this!
Comment 8 Jun Aruga 2016-05-17 06:40 EDT
Created attachment 1158243 [details]
Update to v1.0.2 to fix test suite for Ruby 2.3.0 compatibility

*High light*

I updated the version to latest v1.0.2, that is including the fix for ruby 2.3.0. [1]
I also moved README.md to "%files doc".

[1] https://github.com/typhoeus/typhoeus/commit/8b61442


*Package dependency*

The dependency is no problem.

+ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(typhoeus)'
  => No result

+ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-typhoeus'
rubygem-typhoeus-doc-0:0.7.2-1.fc23.noarch

+ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem(typhoeus)'
rubygem-oauth-0:0.4.7-9.fc24.src
  gem spec: ok, rpm spec: ok
rubygem-webmock-0:1.21.0-1.fc24.src
  gem spec: ok, rpm spec: ok

+ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem-typhoeus'
  => No result

Could you check this patch file?
Thanks.
Comment 9 Vít Ondruch 2016-05-18 04:51:41 EDT
Hi Jun, I approved you in PkgDB, so feel free to push the changes.

One minor nit though. Since you are not doing anything special to fix this bug, IOW the fix is part of the rebase, I would not mention it in Changelog. But that might be just my POV, so use your best judgment ;)
Comment 10 Upstream Release Monitoring 2016-05-18 07:04:17 EDT
jaruga's rubygem-typhoeus-1.0.2-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=766515
Comment 11 Fedora Update System 2016-05-18 07:29:05 EDT
rubygem-typhoeus-1.0.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-20a3699002
Comment 12 Jun Aruga 2016-05-18 07:32:21 EDT
Hi, Vit
Thanks for the review. I updated my comment in Changelog following your idea.
Comment 13 Fedora Update System 2016-05-20 21:34:50 EDT
rubygem-typhoeus-1.0.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-20a3699002
Comment 14 Fedora Update System 2016-05-27 23:35:15 EDT
rubygem-typhoeus-1.0.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.