Bug 1308099 - rubygem-xpath: FTBFS in rawhide
rubygem-xpath: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-xpath (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:26 EST by Fedora Release Engineering
Modified: 2016-06-18 14:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: rubygem-xpath-2.0.0-4.fc25 rubygem-xpath-2.0.0-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-18 14:41:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (108.71 KB, text/plain)
2016-02-13 17:26 EST, Fedora Release Engineering
no flags Details
root.log (84.52 KB, text/plain)
2016-02-13 17:26 EST, Fedora Release Engineering
no flags Details
state.log (645 bytes, text/plain)
2016-02-13 17:26 EST, Fedora Release Engineering
no flags Details
Fix test suite for RSpec 3 compatibility (2.77 KB, patch)
2016-05-25 03:00 EDT, Jun Aruga
no flags Details | Diff
Fix test suite for RSpec 3 compatibility (2.87 KB, patch)
2016-05-26 09:11 EDT, Jun Aruga
no flags Details | Diff
Fix test suite for RSpec 3 compatibility (3.02 KB, patch)
2016-05-26 10:36 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:26:06 EST
Your package rubygem-xpath failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12867858

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:26:09 EST
Created attachment 1126358 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:26:11 EST
Created attachment 1126359 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:26:12 EST
Created attachment 1126360 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:12:00 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Jun Aruga 2016-05-25 02:40:32 EDT
I will fix this!
Comment 6 Jun Aruga 2016-05-25 03:00 EDT
Created attachment 1161320 [details]
Fix test suite for RSpec 3 compatibility

I fixed the test suite for RSpec 3.

# Highlight

- I did not update the rubygem-xpath version because it was latest version.
- Removed below line for rpmlint.
  Provides: rubygem(%{gem_name}) = %{version}

# Others
- Dependency: ok
- Install & Irb check: ok

# Detail for the dependency

$ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem(xpath)' 2> /dev/null
rubygem-capybara-0:2.4.1-2.fc23.noarch
rubygem-capybara-0:2.4.1-3.fc24.noarch
  => gem spec ok
  => rpm spec ok

$ dnf repoquery --enablerepo=rawhide --whatrequires 'rubygem-xpath' 2> /dev/null
rubygem-xpath-doc-0:2.0.0-1.fc22.noarch

$ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem(xpath)'
  => no result

$ dnf repoquery --enablerepo=rawhide-source --arch src --whatrequires 'rubygem-xpath'
  => no result

Could you check this?
Thanks.
Comment 7 Vít Ondruch 2016-05-25 09:16:47 EDT
I'd say that this would be more concise version of your patch:

```
diff --git a/spec/html_spec.rb b/spec/html_spec.rb
index 142cac1..a6e4eeb 100644
--- a/spec/html_spec.rb
+++ b/spec/html_spec.rb
@@ -5,13 +5,13 @@ describe XPath::HTML do
   let(:template) { 'form' }
   let(:template_path) { File.read(File.expand_path("fixtures/#{template}.html", File.dirname(__FILE__))) }
   let(:doc) { Nokogiri::HTML(template_path) }
+  let(:type) {|example| example.metadata[:type]}
 
   def get(*args)
     all(*args).first
   end
 
   def all(*args)
-    type = example.metadata[:type]
     doc.xpath(XPath::HTML.send(subject, *args).to_xpath(type)).map { |node| node[:data] }
   end
 
```

Nevertheless your upstream PR does not pass the test suite, so not sure about it ...
Comment 8 Jun Aruga 2016-05-26 09:11 EDT
Created attachment 1161997 [details]
Fix test suite for RSpec 3 compatibility

> I'd say that this would be more concise version of your patc

Thanks for your review. I updated my patch, and uploaded it again.
Could you check this?
Thanks.
Comment 9 Vít Ondruch 2016-05-26 10:16:58 EDT
LGTM. But since I am not maintainer, lets wait for a few days if you get approved, otherwise I'll build it myself in the near future.
Comment 10 Jun Aruga 2016-05-26 10:36 EDT
Created attachment 1162027 [details]
Fix test suite for RSpec 3 compatibility

I modified the patch a little.
I changed the position of Patch0, under the Source0.
Thanks.
Comment 11 Jun Aruga 2016-06-03 04:52:37 EDT
Hi, Vit.

I wait for 1 week from last time.
After that, I have not been able to see the maintainer's response, and have not been able to get approval.
Could you build it yourself?

Thanks.
Comment 12 Chris Lalancette 2016-06-05 20:02:57 EDT
Ug, am I really the maintainer?  I shouldn't be.  Vit, I've added you to the package administrators so you can push and build as you need.  Should I just orphan it so you can pick it up?
Comment 13 Vít Ondruch 2016-06-06 06:14:56 EDT
(In reply to Chris Lalancette from comment #12)
> Ug, am I really the maintainer?  I shouldn't be.  Vit, I've added you to the
> package administrators so you can push and build as you need.

Thx for that. I could build it anyway, since I am proven packager ;)

> Should I just orphan it so you can pick it up?

Yes, sure. Thx. I guess you should be able to use use "pkgdb-cli give" command to transfer the rights to me without the orphaning step
Comment 14 Upstream Release Monitoring 2016-06-06 07:02:33 EDT
jaruga's rubygem-xpath-2.0.0-4.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=770743
Comment 15 Fedora Update System 2016-06-06 07:24:49 EDT
rubygem-xpath-2.0.0-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-13342931ae
Comment 16 Chris Lalancette 2016-06-06 10:34:17 EDT
All right, I think I've made you the maintainer now.  If not, let me know and I'll look again.  Thanks for taking it over!
Comment 17 Fedora Update System 2016-06-06 13:57:21 EDT
rubygem-xpath-2.0.0-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-13342931ae
Comment 18 Vít Ondruch 2016-06-07 02:52:41 EDT
(In reply to Chris Lalancette from comment #16)
> All right, I think I've made you the maintainer now.

Yep! Thx.
Comment 19 Fedora Update System 2016-06-18 14:41:48 EDT
rubygem-xpath-2.0.0-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.