Bug 1308125 - seq24: FTBFS in rawhide
seq24: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: seq24 (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:29 EST by Fedora Release Engineering
Modified: 2016-02-25 02:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 02:35:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (28.99 KB, text/plain)
2016-02-13 17:29 EST, Fedora Release Engineering
no flags Details
root.log (108.34 KB, text/plain)
2016-02-13 17:29 EST, Fedora Release Engineering
no flags Details
state.log (645 bytes, text/plain)
2016-02-13 17:29 EST, Fedora Release Engineering
no flags Details
Patch to upgrade to 0.9.3 and fix the FTBFS (2.52 KB, patch)
2016-02-18 01:57 EST, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:29:02 EST
Your package seq24 failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12868768

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:29:04 EST
Created attachment 1126436 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:29:05 EST
Created attachment 1126437 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:29:05 EST
Created attachment 1126438 [details]
state.log
Comment 4 Ralf Corsepius 2016-02-18 01:57 EST
Created attachment 1128149 [details]
Patch to upgrade to 0.9.3 and fix the FTBFS

The trigger of this FTBFS is a clash between a package-local class "mutex"
and class "std::mutex", caused by "using namespace std;" within the package.

One approach to address this issue would be to remove "using namespace std;" and to make "std::" explict. Another one is to rename the local "class mutex".

The patch (against Fedora's git master) in the attachment implements the latter, because it's less intrusive and better suited as a temporary work-around.

It renames "class mutex" to "class seq24_mutex." for seg24-0.9.3 (final).
I have not managed to apply this approach to seg24-0.9.3-r131.
Comment 5 Jan Kurik 2016-02-24 10:13:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Ralf Corsepius 2016-02-25 02:08:50 EST
Taking. I am going to apply my proposal above.
Comment 7 Ralf Corsepius 2016-02-25 02:35:09 EST
Changes applied to and packages built for rawhide and f24.

rawhide: http://koji.fedoraproject.org/koji/buildinfo?buildID=738754
f24: http://koji.fedoraproject.org/koji/buildinfo?buildID=738755

Note You need to log in before you can comment on or make changes to this bug.