Bug 1308190 - tomoe-gtk: FTBFS in rawhide
tomoe-gtk: FTBFS in rawhide
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tomoe-gtk (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ding-Yi Chen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:36 EST by Fedora Release Engineering
Modified: 2016-08-17 03:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-17 03:50:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (47.13 KB, text/plain)
2016-02-13 17:36 EST, Fedora Release Engineering
no flags Details
root.log (130.87 KB, text/plain)
2016-02-13 17:36 EST, Fedora Release Engineering
no flags Details
state.log (633 bytes, text/plain)
2016-02-13 17:36 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:36:17 EST
Your package tomoe-gtk failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12874116

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:36:19 EST
Created attachment 1126629 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:36:20 EST
Created attachment 1126630 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:36:21 EST
Created attachment 1126631 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:16:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Fedora Update System 2016-05-11 02:28:49 EDT
tomoe-gtk-0.6.0-24.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b2cc772bfb
Comment 6 Ding-Yi Chen 2016-05-11 03:03:21 EDT
The fix is submitted.
Comment 7 Fedora Update System 2016-05-12 05:42:48 EDT
tomoe-gtk-0.6.0-24.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b2cc772bfb
Comment 8 Fedora Update System 2016-05-20 13:41:12 EDT
tomoe-gtk-0.6.0-24.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 William H. Haller 2016-06-04 21:48:51 EDT
tomoe-gtk-0.6.0-24.fc23 fails to install - not sure what the build problem was.

error: unpacking of archive failed: cpio: lstat
error: tomoe-gtk-0.6.0-24.fc23.x86_64: install failed
error: tomoe-gtk-0.6.0-21.fc22.x86_64: erase skipped

rpm --checksig succeeds
Comment 10 Ding-Yi Chen 2016-06-07 04:22:49 EDT
Perhaps you can try the (In reply to William H. Haller from comment #9)
> tomoe-gtk-0.6.0-24.fc23 fails to install - not sure what the build problem
> was.
> 
> error: unpacking of archive failed: cpio: lstat
> error: tomoe-gtk-0.6.0-24.fc23.x86_64: install failed
> error: tomoe-gtk-0.6.0-21.fc22.x86_64: erase skipped
> 
> rpm --checksig succeeds

Have you tried remove tomoe-gtk then install it again?
Comment 11 William H. Haller 2016-06-07 10:05:54 EDT
I just tried that and it gives the same messages.
Comment 12 William H. Haller 2016-06-07 10:11:49 EDT
Error unpacking rpm package tomoe-gtk-0.6.0-24.fc23.x86_64
Error unpacking rpm package tomoe-gtk-0.6.0-24.fc23.x86_64
error: unpacking of archive failed: cpio: lstat

Sorry - should have added them. There's still a cpio failure. I've downloaded the package again - run a checksig to make sure it is Ok.

tomoe-gtk-0.6.0-24.fc23.x86_64.rpm: rsa sha1 (md5) pgp md5 OK
tomoe-gtk-devel-0.6.0-24.fc23.x86_64.rpm: rsa sha1 (md5) pgp md5 OK

The file that came with fc23 was the 22 release - so it had no issues when I did the f23 upgrade. Just the update seems to have a packaging error.
Comment 13 Ding-Yi Chen 2016-07-20 01:48:02 EDT
(In reply to William H. Haller from comment #12)
> Error unpacking rpm package tomoe-gtk-0.6.0-24.fc23.x86_64
> Error unpacking rpm package tomoe-gtk-0.6.0-24.fc23.x86_64
> error: unpacking of archive failed: cpio: lstat
> 
> Sorry - should have added them. There's still a cpio failure. I've
> downloaded the package again - run a checksig to make sure it is Ok.
> 
> tomoe-gtk-0.6.0-24.fc23.x86_64.rpm: rsa sha1 (md5) pgp md5 OK
> tomoe-gtk-devel-0.6.0-24.fc23.x86_64.rpm: rsa sha1 (md5) pgp md5 OK
> 
> The file that came with fc23 was the 22 release - so it had no issues when I
> did the f23 upgrade. Just the update seems to have a packaging error.

Do you still have this problem?
If there are still the problem, would you mind showing the rpm and dnf version you are using?
Comment 14 William H. Haller 2016-07-20 13:23:33 EDT
  Installing  : tomoe-gtk-0.6.0-24.fc23.x86_64 1/1 
Error unpacking rpm package tomoe-gtk-0.6.0-24.fc23.x86_64
Error unpacking rpm package tomoe-gtk-0.6.0-24.fc23.x86_64
error: unpacking of archive failed: cpio: lstat
tomoe-gtk-0.6.0-24.fc23.x86_64 was supposed to be installed but is not!
Warning: scriptlet or other non-fatal errors occurred during transaction.
  Verifying   : tomoe-gtk-0.6.0-24.fc23.x86_64 1/1 

Failed:
  tomoe-gtk.x86_64 0.6.0-24.fc23

                                                                                                                                                                        rpm-4.13.0-0.rc1.13.fc23.x86_64
dnf-1.1.9-2.fc23.noarch
cpio-2.11-36.fc23.x86_64

I'm not sure what pulled the package in originally. I've since deleted it. However, a new install of the package does still fail as seen above. The downloaded package passes security tests, so there is something about the packaging that is the issue.
Comment 15 Ding-Yi Chen 2016-07-20 20:43:22 EDT
I cannot reproduce your bug. 

Would you mind trying the following command:
Assuming you have installed tomoe:

wget http://download.fedoraproject.org/pub/fedora/linux/updates/23/x86_64/t/tomoe-gtk-0.6.0-24.fc23.x86_64.rpm

Make sure the size is: 62078 
Md5 checksum: 39e57cb3a73cfcd3738922f4660de71a

And then:

sudo rpm -ivh tomoe-gtk-0.6.0-24.fc23.x86_64.rpm

If that works, that means some thing wrong with your repos or cache. You may run "dnf clean all" to clean it, and/or choose more reliable repo.

If that does work, I am out of tricks.
Comment 16 Ding-Yi Chen 2016-07-20 20:45:02 EDT
(In reply to Ding-Yi Chen from comment #15)
> 
> If that works, that means some thing wrong with your repos or cache. You may
> run "dnf clean all" to clean it, and/or choose more reliable repo.
> 

> If that does work, I am out of tricks.

Sorry, the last one should be:
if that does not work, I am out of tricks.
Comment 17 William H. Haller 2016-07-20 23:51:52 EDT
size correct, MD5 checksum correct, rpm -ivh

-rw-r--r--. 1 mirror mirror 62682 May 11 12:42 tomoe-gtk-0.6.0-24.fc23.i686.rpm
-rw-r--r--. 1 mirror mirror 62078 May 11 12:45 tomoe-gtk-0.6.0-24.fc23.x86_64.rpm
-rw-r--r--. 1 mirror mirror 43854 May 11 12:43 tomoe-gtk-devel-0.6.0-24.fc23.i686.rpm
-rw-r--r--. 1 mirror mirror 44350 May 11 12:41 tomoe-gtk-devel-0.6.0-24.fc23.x86_64.rpm

md5sum tomoe-gtk-0.6.0-24*x86*
39e57cb3a73cfcd3738922f4660de71a  tomoe-gtk-0.6.0-24.fc23.x86_64.rpm

rpm -ivh tomoe-gtk-0.6.0-24.fc23.x86_64.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:tomoe-gtk-0.6.0-24.fc23          ################################# [100%]
error: unpacking of archive failed: cpio: lstat
error: tomoe-gtk-0.6.0-24.fc23.x86_64: install failed

Is there any chance that a new file in f23 is trying to use a file that was the wrong type in a previous version (like a regular file instead of a directory) or something really weird like that - or something that would normally be created by some other tomoe sort of file that might not yet be created? It's got to be something like that since cpio is failing if it works for you. If the contents are correct based on above sums then cpio must not be able to extract due to other file. F22 was installed fine by something though so it has to be some different file or possibly user creation from before the moving of the UIDs?
Comment 18 Ding-Yi Chen 2016-07-21 01:25:39 EDT
Some more tricks:

Try:
rpm -qpl tomoe-gtk-0.6.0-24.fc23.x86_64.rpm

If that does not work, try:

rpm2cpio tomoe-gtk-0.6.0-24.fc23.x86_64.rpm| cpio -dtv

And

lsb_release -a

If above does not work, try fixing your partition.
Comment 19 William H. Haller 2016-07-21 11:52:03 EDT
All right.

The problem is that ./usr/share/locale/ja.po is a file in fedora 22 (and I'm pretty sure in other releases as well) and not a directory, so when it tries to create ./usr/share/locale/ja.po/LC_MESSAGES/tomoe-gtk.mo it fails.

That isn't a surprise since I'm pretty sure it should be /usr/share/locale/ja/LC_MESSAGES/tomoe-gtk.mo and not ja.po
Comment 20 Ding-Yi Chen 2016-07-21 22:07:38 EDT
(In reply to William H. Haller from comment #19)
> All right.
> 
> The problem is that ./usr/share/locale/ja.po is a file in fedora 22 (and I'm
> pretty sure in other releases as well) and not a directory, so when it tries
> to create ./usr/share/locale/ja.po/LC_MESSAGES/tomoe-gtk.mo it fails.


> That isn't a surprise since I'm pretty sure it should be
> /usr/share/locale/ja/LC_MESSAGES/tomoe-gtk.mo and not ja.po

Well spot! We are getting somewhere.
But in that cases, the error message will more likely to be file conflict instead of cpio error.

Fix is on the way.
Comment 21 Ding-Yi Chen 2016-08-17 03:50:52 EDT
Fixed with tomoe-gtk-0.6.0-25.fc23

Note You need to log in before you can comment on or make changes to this bug.