Bug 1308228 - vifm: FTBFS in rawhide
vifm: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vifm (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Boeckel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:40 EST by Fedora Release Engineering
Modified: 2016-04-23 21:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-23 21:05:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (75.59 KB, text/plain)
2016-02-13 17:40 EST, Fedora Release Engineering
no flags Details
root.log (84.18 KB, text/plain)
2016-02-13 17:40 EST, Fedora Release Engineering
no flags Details
state.log (601 bytes, text/plain)
2016-02-13 17:40 EST, Fedora Release Engineering
no flags Details
Patch to address this issue (1.60 KB, patch)
2016-03-23 02:13 EDT, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:40:24 EST
Your package vifm failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12876872

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:40:26 EST
Created attachment 1126752 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:40:27 EST
Created attachment 1126753 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:40:28 EST
Created attachment 1126754 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:18:39 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Ralf Corsepius 2016-03-23 02:13 EDT
Created attachment 1139337 [details]
Patch to address this issue

This FTBFS is caused by mixing direct installation of docs (make install) into %{_pkgdocdir} and installation of docs through "%doc <relative path>".

The patch in the attachment (against fedora git/master) contains how I would address this issue and a couple of further minor packaging issues.

Unless somebody objects, I intend to apply this patch in near future.
Comment 6 Upstream Release Monitoring 2016-03-30 20:39:41 EDT
mathstuf's vifm-0.8-3.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=750045
Comment 7 Upstream Release Monitoring 2016-04-23 21:04:14 EDT
mathstuf's vifm-0.8.1a-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=757144

Note You need to log in before you can comment on or make changes to this bug.