Bug 130825 - gcc 3.[45] with -std=c99, isascii() not declared in ctype.h
gcc 3.[45] with -std=c99, isascii() not declared in ctype.h
Status: CLOSED DUPLICATE of bug 130815
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-24 18:26 EDT by John Ellson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2004-08-24 18:26:13 EDT
Description of problem:
isascii() not declared in ctype.h contrary to man 3 isascii

Version-Release number of selected component (if applicable):
glibc-headers-2.3.3-46
gcc35-3.5.0-0.9
gcc-3.4.1-9

How reproducible:
100%

Steps to Reproduce:
1.

ellson@ontap:~> cat bug.c
#include <ctype.h>
int main() {
        return (isascii(32));
}
ellson@ontap:~> gcc35 -std=c99 bug.c
bug.c: In function `main':
bug.c:3: warning: implicit declaration of function 'isascii'
ellson@ontap:~>

2.
3.
  
Actual results:
warning about implicit declaration

Expected results:
no warning

Additional info:
Comment 1 Jakub Jelinek 2004-08-30 02:36:33 EDT
isascii is SysV, misc or X/Open API.

*** This bug has been marked as a duplicate of 130815 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.