Bug 1308261 - yadex: FTBFS in rawhide
yadex: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yadex (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2016-02-13 17:43 EST by Fedora Release Engineering
Modified: 2016-03-29 15:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: yadex-1.7.0-37.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 15:34:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (8.12 KB, text/plain)
2016-02-13 17:43 EST, Fedora Release Engineering
no flags Details
root.log (88.75 KB, text/plain)
2016-02-13 17:43 EST, Fedora Release Engineering
no flags Details
state.log (617 bytes, text/plain)
2016-02-13 17:43 EST, Fedora Release Engineering
no flags Details
Patch to fix the FTBFS (1.78 KB, patch)
2016-03-21 07:05 EDT, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:43:46 EST
Your package yadex failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12880273

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:43:48 EST
Created attachment 1126851 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:43:49 EST
Created attachment 1126852 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:43:50 EST
Created attachment 1126853 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:19:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Ralf Corsepius 2016-03-21 07:05 EDT
Created attachment 1138533 [details]
Patch to fix the FTBFS

This FTBFS is caused by 2 issues:

1. The spec lacks a couple of BR:s, esp. on perl-modules, which have been split out from the main perl-package.

2. With 1. fixed, building fails due to c++14 incompatibilities.
A quick fix would be to use CXX="g++ -std=gnu++03"

I am proposing the patch (against fedora git/master) in the attachment, which should implement 1. and 2.

Unless somebody objects, I indent to apply this patch in near future.
Comment 6 Ralf Corsepius 2016-03-23 07:47:30 EDT
Taking ... Applying my patch
Comment 7 Upstream Release Monitoring 2016-03-23 08:00:32 EDT
corsepiu's yadex-1.7.0-37.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=748429
Comment 8 Fedora Update System 2016-03-23 08:29:05 EDT
yadex-1.7.0-37.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-93dd483379
Comment 9 Fedora Update System 2016-03-23 15:55:44 EDT
yadex-1.7.0-37.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-93dd483379
Comment 10 Fedora Update System 2016-03-29 15:34:06 EDT
yadex-1.7.0-37.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.