Bug 1308307 - dnf does not support --'skip-broken'
dnf does not support --'skip-broken'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-14 02:20 EST by cornel panceac
Modified: 2016-02-19 12:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 10:20:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf skip broken (1.97 KB, text/plain)
2016-02-14 02:20 EST, cornel panceac
no flags Details

  None (edit)
Description cornel panceac 2016-02-14 02:20:19 EST
Created attachment 1126963 [details]
dnf skip broken

Description of problem:
trying 'yum info cegui', it fails because dnf translates this into:

'/usr/bin/dnf --skip-broken info cegui'

Leaving aside i don't understand why --skip-broken is needed for a 'info' command, leving aside i don't understand why 'yum' wihout 'skip-broken' is translated into dnf with 'skip-broen', leaving aside i don't understand why the same info is presented twice, i also don't understand why dnf --skip-broken is not working.

Version-Release number of selected component (if applicable):
dnf-1.1.6-2.fc23.noarch

See attachment for details.


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michael Mráka 2016-02-15 03:18:35 EST
This is most likely caused by your local configuration.
Dnf does not add --skip-broken when redirecting from yum.
Maybe you have set an alias yum='yum --skip-broken' somewhere?
Comment 2 cornel panceac 2016-02-15 14:37:02 EST
Yes. This is correct. I have a line

alias yum='yum --skip-broken'

in root's .bashrc . 
Of course this is inherited from older Fedora releases. I ill update it to use yum-deprecated.
Comment 3 Michal Luscon 2016-02-19 10:20:32 EST
I believe this can be closed now.
Comment 4 cornel panceac 2016-02-19 12:41:20 EST
Ok, thank you.

Note You need to log in before you can comment on or make changes to this bug.