Bug 1308309 - Deployment finished successfully without notification to user
Summary: Deployment finished successfully without notification to user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Angus Thomas
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-14 07:28 UTC by Ronnie Rasouli
Modified: 2016-12-14 15:22 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:22:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Ronnie Rasouli 2016-02-14 07:28:08 UTC
Description of problem:

There seems to be a new feature that the deployment phase outputs the resources to shell screen.

The deployment ends without notification to user that it finished succesfully
2016-02-14 06:30:57 [ControllerConfig]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:30:58 [NodeUserData]: CREATE_COMPLETE  state changed
2016-02-14 06:30:58 [UserData]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:30:58 [NodeAdminUserData]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:30:59 [overcloud-Controller-tfvxs6eiy2sc-2-onnjcbuyma56]: CREATE_IN_PROGRESS  Stack CREATE started
2016-02-14 06:30:59 [ControllerConfig]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:30:59 [NodeAdminUserData]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:00 [UserData]: CREATE_COMPLETE  state changed
2016-02-14 06:31:00 [Controller]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:00 [UpdateConfig]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:01 [UpdateConfig]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:02 [NodeUserData]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:03 [NodeUserData]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:05 [ControllerConfig]: CREATE_COMPLETE  state changed
2016-02-14 06:31:07 [ControllerConfig]: CREATE_COMPLETE  state changed
2016-02-14 06:31:07 [UpdateConfig]: CREATE_COMPLETE  state changed
2016-02-14 06:31:08 [NodeAdminUserData]: CREATE_COMPLETE  state changed
2016-02-14 06:31:10 [NodeAdminUserData]: CREATE_COMPLETE  state changed
2016-02-14 06:31:10 [UpdateConfig]: CREATE_COMPLETE  state changed
2016-02-14 06:31:11 [NodeUserData]: CREATE_COMPLETE  state changed
2016-02-14 06:31:11 [NodeUserData]: CREATE_COMPLETE  state changed
2016-02-14 06:31:11 [UserData]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:12 [UserData]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:13 [UserData]: CREATE_COMPLETE  state changed
2016-02-14 06:31:13 [Controller]: CREATE_IN_PROGRESS  state changed
2016-02-14 06:31:14 [UserData]: CREATE_COMPLETE  state changed
2016-02-14 06:31:14 [Controller]: CREATE_IN_PROGRESS  state changed

[stack@instack ~]$ heat stack-list
+--------------------------------------+------------+-----------------+---------------------+--------------+
| id                                   | stack_name | stack_status    | creation_time       | updated_time |
+--------------------------------------+------------+-----------------+---------------------+--------------+
| a00b40c4-720b-437f-970c-7dc5c1f4d2aa | overcloud  | CREATE_COMPLETE | 2016-02-14T06:29:42 | None         |
+--------------------------------------+------------+-----------------+---------------------+--------------+







Version-Release number of selected component (if applicable):

openstack-heat-engine-5.0.1-1.el7ost.noarch
openstaopenstack-tripleo-heat-templates-kilo-0.8.7-12.el7ost.noarch

openstack-tripleo-heat-templates-kilo-0.8.7-12.el7ost.noarch
director 8 puddle - 2016-02-11.1

How reproducible:
100%

Steps to Reproduce:
1. run a deployment of the latest RHOS dircetor 
openstack overcloud deploy \
--templates ~/templates/my-overcloud \
--control-scale 3 --compute-scale 1 \
--ntp-server clock.redhat.com \
--libvirt-type qemu \
-e ~/templates/my-overcloud/environments/network-isolation.yaml \
-e ~/templates/my-overcloud/environments/puppet-pacemaker.yaml  \
-e ~/templates/network-environment.yaml \
-e ~/templates/firstboot-environment.yaml \
-e templates/snmpd.yaml
2. wait until the output stuck in 
2016-02-14 06:31:14 [Controller]: CREATE_IN_PROGRESS  state changed

3. monitor on second shell 
heat resource-list overcloud | grep -v COMPLETE
output is empty


Actual results:
The deployment output stuck although it successfully endded

Expected results:

Output notification to user in case that the deployment passed/failed

Additional info:

Comment 1 Ronnie Rasouli 2016-02-14 08:57:54 UTC
It seems that the overcloud deployment did not finalize - overcloudrc is missing from /home/stack

Comment 2 Ronnie Rasouli 2016-02-14 13:53:35 UTC
Deleting the overcloud and redeploying finished successfully

Comment 4 Mike Burns 2016-04-07 21:11:06 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 6 Jaromir Coufal 2016-10-11 13:41:50 UTC
Is this reproducible?

Comment 7 James Slagle 2016-10-14 15:19:35 UTC
i believe this was fixed in a previous release, please retest and confirm.

Comment 10 errata-xmlrpc 2016-12-14 15:22:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.