Bug 1308313 - osm_default_subdomain would be removed from ansible inventory when run atomic-openshift-installer unattended
osm_default_subdomain would be removed from ansible inventory when run atomic...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-14 02:45 EST by Gaoyun Pei
Modified: 2016-02-29 07:57 EST (History)
4 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.40-1.git.39.abba5ee.el7aos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 07:57:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2016-02-14 02:45:57 EST
Description of problem:
atomic-openshift-installer is allowed to define default subdomain now, but once user choose editing the installer.cfg.yml during interaction and run `atomic-openshift-installer --unattended install` to restart the install, osm_default_subdomain was removed from ansible inventory.

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.40-1.git.22.da21865.el7aos.noarch

How reproducible:
Always

Steps to Reproduce:
1.Run 'atomic-openshift-installer install' 
2.Input the required information including subdomain name
3.Choose "N" for the facts confirm, edit the installer.cfg.yml and run 'atomic-openshift-installer --unattended install'

Actual results:
When rerun installer, osm_default_subdomain was removed from ansible inventory

Expected results:
The "osm_default_subdomain" option shouldn't be missed in ansible inventory.

Additional info:
Comment 3 Gaoyun Pei 2016-02-15 21:46:46 EST
Verify this bug with atomic-openshift-utils-3.0.41-1.git.0.2446a82.el7aos.noarch

Once define subdomain during interaction, master_routingconfig_subdomain would be written in installer.cfg.yml. When rerun installer, osm_default_subdomain still could be configured in ansible inventory.
Comment 5 errata-xmlrpc 2016-02-29 07:57:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0311

Note You need to log in before you can comment on or make changes to this bug.