Bug 1308322 - [online]Cannot open WebSocket after creating tomcat8/tomcat7 application via installed template on web console
[online]Cannot open WebSocket after creating tomcat8/tomcat7 application vi...
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: kconner
Wang Haoran
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-14 03:58 EST by wewang
Modified: 2016-07-22 02:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-22 02:20:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wewang 2016-02-14 03:58:03 EST
Description of problem:
Cannot open WebSocket after creating tomcat8 basic application via installed template on web console

Steps to Reproduce:
1.  Login to openshift from web console
2.  Create a project, test
3.  Create secret under this project via cli
    $oc create  -f application-templates/webserver/jws-app-secret.json  
4.  Click into the test project and browse Add to project -> All templates
5.  Click jws30-tomcat8-basic-s2i
6.  Check builds and pods 
7.  Wait build to complete, access app via the url <route>/websocket-chat/
 


Actual results:
error appears :Info: WebSocket closed. when access app via route

Expected results:
when access app via route ,can display WebSocket open
Comment 1 Steve Speicher 2016-04-20 14:52:31 EDT
What are the details of the online environment that was used when this problem was found? 

There has been some work to fix router config of the hosted environments, that allowed for websockets to work.
Comment 2 Abhishek Gupta 2016-07-21 17:01:05 EDT
QE: As Steve mentioned above, there have been changes to the Online environment since this bug was file. Can you please verify this bug to see if the issue still exists?
Comment 3 wewang 2016-07-22 02:20:16 EDT
now there's no jws30-tomcat8-basic-s2i template in online env ,so close the bug

Note You need to log in before you can comment on or make changes to this bug.