Bug 1308359 - [abrt] htop: setCommand(): htop killed by SIGABRT
[abrt] htop: setCommand(): htop killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: htop (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Morten Stevens
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e060cea43ea788a86e316283457...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-14 14:23 EST by Mikhail
Modified: 2016-03-04 15:54 EST (History)
5 users (show)

See Also:
Fixed In Version: htop-2.0.0-2.fc23 htop-2.0.0-2.fc22 htop-2.0.0-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 15:52:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (16.46 KB, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: cgroup (200 bytes, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: core_backtrace (3.28 KB, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: dso_list (930 bytes, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: environ (3.57 KB, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: maps (4.35 KB, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: mountinfo (4.11 KB, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: namespaces (85 bytes, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: open_fds (287 bytes, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: proc_pid_status (1.01 KB, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
File: var_log_messages (307 bytes, text/plain)
2016-02-14 14:23 EST, Mikhail
no flags Details
htoprc file that causes the crash (648 bytes, text/plain)
2016-02-15 08:59 EST, Ting-Wei Lan
no flags Details

  None (edit)
Description Mikhail 2016-02-14 14:23:10 EST
Description of problem:
htop begin crash on every lauch after update

Version-Release number of selected component:
htop-2.0.0-1.fc23

Additional info:
reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        htop
crash_function: setCommand
executable:     /usr/bin/htop
global_pid:     15717
kernel:         4.3.5-300.fc23.x86_64+debug
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (4 frames)
 #6 setCommand at linux/LinuxProcessList.c:452
 #7 LinuxProcessList_recurseProcTree at linux/LinuxProcessList.c:608
 #9 ProcessList_goThroughEntries at linux/LinuxProcessList.c:774
 #10 ProcessList_scan at ProcessList.c:317
Comment 1 Mikhail 2016-02-14 14:23:15 EST
Created attachment 1127060 [details]
File: backtrace
Comment 2 Mikhail 2016-02-14 14:23:17 EST
Created attachment 1127061 [details]
File: cgroup
Comment 3 Mikhail 2016-02-14 14:23:18 EST
Created attachment 1127062 [details]
File: core_backtrace
Comment 4 Mikhail 2016-02-14 14:23:19 EST
Created attachment 1127063 [details]
File: dso_list
Comment 5 Mikhail 2016-02-14 14:23:21 EST
Created attachment 1127064 [details]
File: environ
Comment 6 Mikhail 2016-02-14 14:23:22 EST
Created attachment 1127065 [details]
File: limits
Comment 7 Mikhail 2016-02-14 14:23:24 EST
Created attachment 1127066 [details]
File: maps
Comment 8 Mikhail 2016-02-14 14:23:27 EST
Created attachment 1127067 [details]
File: mountinfo
Comment 9 Mikhail 2016-02-14 14:23:28 EST
Created attachment 1127068 [details]
File: namespaces
Comment 10 Mikhail 2016-02-14 14:23:29 EST
Created attachment 1127069 [details]
File: open_fds
Comment 11 Mikhail 2016-02-14 14:23:31 EST
Created attachment 1127070 [details]
File: proc_pid_status
Comment 12 Mikhail 2016-02-14 14:23:32 EST
Created attachment 1127071 [details]
File: var_log_messages
Comment 13 Ting-Wei Lan 2016-02-14 23:38:56 EST
It crashes when using the configuration file written by old versions of htop.
Comment 14 Morten Stevens 2016-02-15 08:52:24 EST
(In reply to Ting-Wei Lan from comment #13)
> It crashes when using the configuration file written by old versions of htop.

I'm not able to reproduce this.
Comment 15 Ting-Wei Lan 2016-02-15 08:59 EST
Created attachment 1127293 [details]
htoprc file that causes the crash
Comment 16 Morten Stevens 2016-02-15 09:05:19 EST
(In reply to Ting-Wei Lan from comment #15)
> Created attachment 1127293 [details]
> htoprc file that causes the crash

Thank you. I'm now able to reproduce this.
Comment 17 Fedora Update System 2016-02-15 09:56:46 EST
htop-2.0.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5ff98451f1
Comment 18 Fedora Update System 2016-02-15 10:02:16 EST
htop-2.0.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a0f0395b6b
Comment 19 Fedora Update System 2016-02-15 10:02:24 EST
htop-2.0.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a0f0395b6b
Comment 20 Fedora Update System 2016-02-15 10:03:44 EST
htop-2.0.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c9171bbc89
Comment 21 Fedora Update System 2016-02-15 10:03:45 EST
htop-2.0.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c9171bbc89
Comment 22 Fedora Update System 2016-02-16 23:50:02 EST
htop-2.0.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c9171bbc89
Comment 23 Fedora Update System 2016-02-17 01:27:56 EST
htop-2.0.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a0f0395b6b
Comment 24 Fedora Update System 2016-02-17 01:29:13 EST
htop-2.0.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5ff98451f1
Comment 25 Fedora Update System 2016-02-17 15:52:45 EST
htop-2.0.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2016-02-25 03:53:48 EST
htop-2.0.0-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2016-03-04 15:54:08 EST
htop-2.0.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.