Bug 1308377 - Dependency on older ghc-gio blocks upgrade of ghc-gio and ghc-gtk
Dependency on older ghc-gio blocks upgrade of ghc-gio and ghc-gtk
Status: CLOSED DUPLICATE of bug 1152063
Product: Fedora
Classification: Fedora
Component: leksah-server (Show other bugs)
24
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-14 18:01 EST by Peter Trenholme
Modified: 2016-05-09 06:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-09 06:40:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2016-02-14 18:01:53 EST
Description of problem: leksha-server depends on gdc-gio 0.13.9-1, so the posted upgrade to gdc-gio 0.13.9-2 is blocked, and the upgrade of ghc-gtk to 0.13.9-2, which depends on gtk=gio 0.13.9-2 is also blocked.

Version-Release number of selected component (if applicable): 0.14.3.1-4.fc24

How reproducible: Every time

Steps to Reproduce: run "dnf upgrade"

Actual results:
Skipping packages with broken dependencies:
 ghc-gio                   x86_64 0.13.1.0-2.fc24                rawhide  228 k
 ghc-gtk                   x86_64 0.13.9-2.fc24                  rawhide  1.4 M


Expected results: No packages skipped

Additional info:

Is it reasonable to have dependencies on exact component versions?
Comment 1 Jan Kurik 2016-02-24 10:44:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Peter Robinson 2016-05-09 06:40:42 EDT

*** This bug has been marked as a duplicate of bug 1152063 ***

Note You need to log in before you can comment on or make changes to this bug.