This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 130840 - evolution-connector password dialog displays your password as you type, rather than asterisks
evolution-connector password dialog displays your password as you type, rathe...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-24 21:50 EDT by Dave Malcolm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 15:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2004-08-24 21:50:01 EDT
Description of problem:
evolution-connector password dialog displays password as you type,
rather than asterisks

Version-Release number of selected component (if applicable):
evolution-connector-1.5.92-3

How reproducible:
100%

Steps to Reproduce:
1. Set up an MS Exchange account within Evolution
2. "Enter Password" dialog appears next time you Send/Receive email
3. Try typing into password entry field
  
Actual results:
Password appears on-screen in plaintext

Expected results:
Asterisks so that the person looking over my shoulder doesn't see it.

Additional info:
Comment 1 Dave Malcolm 2004-08-25 13:29:02 EDT
Have tracked this down; it's a API mismatch between connector version
1.5.92 and evolution version 1.5.93; they've added a flag which must
be set to hide the password to e_passwords_get_password (since in
theory this can be used for non-password entries, though it's a bad
API name in that case, if you ask me...)

Should be fixed once I bump connector version to 1.5.93
Comment 2 Dave Malcolm 2004-08-27 15:29:20 EDT
Fixed now in Rawhide: evolution-connector-1.5.93-1

Note You need to log in before you can comment on or make changes to this bug.