Bug 1308412 - Fail to install containerized HA master env on RHEL7
Fail to install containerized HA master env on RHEL7
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 01:38 EST by Gaoyun Pei
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.40-1.git.35.7f5463c.el7aos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 07:58:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2016-02-15 01:38:35 EST
Description of problem:
During setting up an HA master env, ansible would mask master service if it's a native way and the host is not Atomic. 

So when installing a containerized HA master on RHEL7 host, ansible still try to mask the atomic-openshift-master service, but failed for it doesn't have atomic-openshift-master.service file. 

Version-Release number of selected component (if applicable):
openshift-ansible-3.0.40-1.git.22.da21865.el7aos.noarch

How reproducible:
Always

Steps to Reproduce:
1.Run 'atomic-openshift-installer install', input 3 masters(Container based) and lb information

Actual results:
TASK: [openshift_master | Mask master service] ******************************** 
failed: [10.66.x.x] => {"changed": true, "cmd": ["systemctl", "mask", "atomic-openshift-master"], "delta": "0:00:00.016835", "end": "2016-02-15 11:28:29.128125", "rc": 1, "start": "2016-02-15 11:28:29.111290", "warnings": []}
stderr: Failed to execute operation: Access denied


Expected results:
Should not mask master service on containerized env.

Additional info:
Comment 3 Gaoyun Pei 2016-02-16 02:57:42 EST
Verify this bug with openshift-ansible-3.0.41-1.git.0.2446a82.el7aos.noarch

Ansible would not mask master service when it's running a containerized install, and a containerized HA master env could installed.
Comment 5 errata-xmlrpc 2016-02-29 07:58:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0311

Note You need to log in before you can comment on or make changes to this bug.