Bug 1308422 - nova boot fails Unexpected API Error keystoneclient.exceptions.NotFound'> (HTTP 500) - when selecting net-id
nova boot fails Unexpected API Error keystoneclient.exceptions.NotFound'> (HT...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 8.0 (Liberty)
Assigned To: James Slagle
Alexander Chuzhoy
: BuildBlocker
: 1309135 (view as bug list)
Depends On:
Blocks: 1261979 1310828
  Show dependency treegraph
 
Reported: 2016-02-15 02:32 EST by Ronnie Rasouli
Modified: 2016-04-07 17:47 EDT (History)
28 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.8-2.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, '/v2.0' was missing from the end of the URL specified in the admin_auth_url setting in the [neutron] section of /etc/nova/nova.conf. This would prevent Nova from being able to boot instances because it could not connect to the Keystone catalog to query for the Neutron service endpoint to create and bind the port for instances. Now, '/v2.0' is correctly added to the end of the URL specified in the admin_auth_url setting, allowing instances to be started successfully after deploying an overcloud with the director.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:47:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1533260 None None None 2016-02-15 02:32 EST

  None (edit)
Description Ronnie Rasouli 2016-02-15 02:32:32 EST
Description of problem:

Booting an instance by selecting net-id fails
[stack@instack ~]$ neutron net-list
+--------------------------------------+----------------------------------------------------+-------------------------------------------------------+
| id                                   | name                                               | subnets                                               |
+--------------------------------------+----------------------------------------------------+-------------------------------------------------------+
| eecc86de-b92d-4f6d-8b86-5c2d41715ba3 | tenant-net                                         | ad3c67eb-b7e8-40e2-9b62-6c42cff9672c 192.168.0.0/24   |
| b9df49e3-9d83-44f5-8137-66ea44c15759 | HA network tenant bb5b83f3957140dab90527540e28f07a | 2aec8fb2-0c5f-48b5-8553-c6cee31120e4 169.254.192.0/18 |
| 09f656ec-5349-4683-848f-a53cd26da69f | nova                                               | a2bc9476-c38e-40ee-9da4-b22ee926661f 172.16.23.0/24   |
+--------------------------------------+----------------------------------------------------+-------------------------------------------------------+
[stack@instack ~]$  nova boot --image private_rhel64 --flavor m1.tiny --nic net-id=09f656ec-5349-4683-848f-a53cd26da69f  aaa
ERROR (ClientException): Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible.
<class 'keystoneclient.exceptions.NotFound'> (HTTP 500) (Request-ID: req-0f486504-99b5-429c-88c5-362f2522dc73)




in case booting with a default network the boot process has been succeeded.


[stack@seal01 ~]$ neutron net-list
\+--------------------------------------+------------+-----------------------------------------------------+
| id                                   | name       | subnets                                             |
+--------------------------------------+------------+-----------------------------------------------------+
| b6180ce0-b96a-469c-a86f-5922e5731e61 | tenant-net | 00f4e7bc-5a73-40c3-ad51-22ab1065b377 192.168.0.0/24 |
+--------------------------------------+------------+-----------------------------------------------------+
[stack@seal01 ~]$ nova boot --image private_rhel64 --flavor m1.tiny bbb
+--------------------------------------+-------------------------------------------------------+
| Property                             | Value                                                 |
+--------------------------------------+-------------------------------------------------------+
| OS-DCF:diskConfig                    | MANUAL                                                |
| OS-EXT-AZ:availability_zone          |                                                       |
| OS-EXT-SRV-ATTR:host                 | -                                                     |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | -                                                     |
| OS-EXT-SRV-ATTR:instance_name        | instance-00000002                                     |
| OS-EXT-STS:power_state               | 0                                                     |
| OS-EXT-STS:task_state                | scheduling                                            |
| OS-EXT-STS:vm_state                  | building                                              |
| OS-SRV-USG:launched_at               | -                                                     |
| OS-SRV-USG:terminated_at             | -                                                     |
| accessIPv4                           |                                                       |
| accessIPv6                           |                                                       |
| adminPass                            | HWQaf2RGth8n                                          |
| config_drive                         |                                                       |
| created                              | 2016-02-15T07:18:56Z                                  |
| flavor                               | m1.tiny (1)                                           |
| hostId                               |                                                       |
| id                                   | 276e0b1e-997a-4dcc-86ca-44795bbc14a4                  |
| image                                | private_rhel64 (5802c5ab-b8fa-483f-8d8b-37a843282126) |
| key_name                             | -                                                     |
| metadata                             | {}                                                    |
| name                                 | bbb                                                   |
| os-extended-volumes:volumes_attached | []                                                    |
| progress                             | 0                                                     |
| security_groups                      | default                                               |
| status                               | BUILD                                                 |
| tenant_id                            | 8e0425f234504da5ae36d1bac9803701                      |
| updated                              | 2016-02-15T07:18:56Z                                  |
| user_id                              | f95c503435aa483ca4219d24c19773d7                      |
+--------------------------------------+-------------------------------------------------------+


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.create multiple networks in overcloud
2.create image glance image-create
3.boot from a selected network by --nic net-id={netowrk UUID}

Actual results:

failed to boot instance with error 500

Expected results:

Ability to select booting from selected network

Additional info:

Tested on BM devices and on virtual. 
Network isolation

nova-api log in http://file.tlv.redhat.com/~rrasouli/uploads/
Comment 1 Ronnie Rasouli 2016-02-15 02:33:29 EST
Versions:

openstack-nova-compute-12.0.1-2.el7ost.noarch
openstack-nova-scheduler-12.0.1-2.el7ost.noarch
openstack-nova-cert-12.0.1-2.el7ost.noarch
python-nova-12.0.1-2.el7ost.noarch
openstack-nova-common-12.0.1-2.el7ost.noarch
openstack-nova-conductor-12.0.1-2.el7ost.noarch
openstack-nova-api-12.0.1-2.el7ost.noarch
python-novaclient-3.1.0-2.el7ost.noarch

openstack-neutron-common-7.0.1-9.el7ost.noarch
openstack-neutron-7.0.1-9.el7ost.noarch
python-neutron-7.0.1-9.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch
openstack-neutron-openvswitch-7.0.1-9.el7ost.noarch
openstack-neutron-ml2-7.0.1-9.el7ost.noarch
Comment 4 bkopilov 2016-02-18 03:07:51 EST
Hi , 

The root cause :

In your nova.conf file under controllers :

/etc/nova/nova.conf:2687:admin_auth_url=http://192.0.2.18:35357

The keystone endpoint is configured without /v2.0

I fixed it and it works .


Workaround: 
change the admin_auth_url to  http://192.0.2.18:35357/v2.0 on all controllers.
pcs resource restart openstack-nova-api-clone

The component should be OSP-D installer and not nova.

Benny
Comment 5 Hugh Brock 2016-02-18 03:31:12 EST
Moving this to rhelosp-director since it seems to be a configuration bug.
Comment 6 Raoul Scarazzini 2016-02-23 04:35:35 EST
*** Bug 1309135 has been marked as a duplicate of this bug. ***
Comment 8 bkopilov 2016-02-24 01:06:49 EST
The fix should be implemented in the installer .
Benny
Comment 9 James Slagle 2016-02-25 14:27:57 EST
the issue here was with one of the downstream patches that we needed to drop from the build, https://code.engineering.redhat.com/gerrit/gitweb?p=openstack-tripleo-heat-templates.git;a=commit;h=fda2f616b42e9c204cab5bf64ef4d9e8af961875
Comment 12 Alexander Chuzhoy 2016-03-11 10:31:24 EST
Verified:

Environment:
openstack-tripleo-heat-templates-0.8.9-1.el7ost.noarch


The reported issue doesn't reproduce.
Comment 13 Kurt Hey 2016-03-17 15:02:50 EDT
Verified to be fixed in Beta 8.
Comment 15 errata-xmlrpc 2016-04-07 17:47:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.