Bug 1308426 - Overcloud installation with external ceph sets wrong parameters in ceph.conf [NEEDINFO]
Overcloud installation with external ceph sets wrong parameters in ceph.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 10.0 (Newton)
Assigned To: leseb
Yogev Rabl
: Triaged
Depends On:
Blocks: 1411905 1440200 1472811
  Show dependency treegraph
 
Reported: 2016-02-15 03:28 EST by Yogev Rabl
Modified: 2017-07-19 08:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-tripleo-0.0.8-0.2.4de13b3git.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1411905 (view as bug list)
Environment:
Last Closed: 2016-12-14 10:23:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pkovacs: needinfo? (shan)


Attachments (Terms of Use)

  None (edit)
Description Yogev Rabl 2016-02-15 03:28:02 EST
Description of problem:
The installation of overcloud with external ceph requires few parameters in puppet-ceph-external.yaml: CephClusterFSID, CephClientKey, CephExternalMonHost, the names of the pools and Ceph user. 
The Ceph configuration file in the overcloud has configurations that are different from the configuration of the Ceph cluster.

For an example, this is the Ceph configuration of the overcloud:
[global]
osd_pool_default_pgp_num = 128 #can be changed in ../puppet/hieradata/ceph.yaml
osd_pool_default_min_size = 1 #can be changed in ../puppet/hieradata/ceph.yaml
auth_service_required = cephx
fsid = 792a0c5d-2f7d-4720-9232-d662de74fe6a
cluster_network = 10.35.182.138/24 #irrelevant parameter in this case, remove/set different parameter in ceph-external.yaml
auth_supported = cephx
auth_cluster_required = cephx
mon_host = 10.35.70.12
auth_client_required = cephx
osd_pool_default_size = 3 #can be changed in ../puppet/hieradata/ceph.yaml
osd_pool_default_pg_num = 128 #can be changed in ../puppet/hieradata/ceph.yaml
public_network = 10.35.182.138/24 #a there's a different parameter in the cluster's ceph.conf 

[osd]
osd_journal_size = 1024 #can be changed in ../puppet/hieradata/ceph.yaml
Version-Release number of selected component (if applicable):
python-tripleoclient-0.1.1-2.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch
openstack-tripleo-heat-templates-kilo-0.8.7-12.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-2.el7ost.noarch
openstack-tripleo-heat-templates-0.8.7-12.el7ost.noarch
openstack-tripleo-0.0.7-1.el7ost.noarch
openstack-tripleo-common-0.1.1-1.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy an overcloud with puppet-external-ceph.yaml

Actual results:
The Ceph configuration on the Openstack controllers are different from the configuration in the Ceph cluster. 

Expected results:
The Ceph configuration file should be the same on both Openstack controllers and Ceph cluster.

Additional info:
Comment 2 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 8 Yogev Rabl 2016-11-22 03:01:50 EST
verified on openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch
Comment 11 errata-xmlrpc 2016-12-14 10:23:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.