Bug 1308456 - [Disconnected] User is allowed to upload different manifest to successfully completed deployment
[Disconnected] User is allowed to upload different manifest to successfully c...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity low
: ga
: 1.0
Assigned To: John Matthews
Tasos Papaioannou
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 04:40 EST by Antonin Pagac
Modified: 2016-09-13 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2016-02-15 04:40:35 EST
Description of problem:
After successful deployment with restricted network access, user is allowed to go back to step 'Content Provider' and choose and upload a different manifest file successfully.
This action does not produce any results and should be disabled for completed deployments.

Version-Release number of selected component (if applicable):
TP2 RC9
RHCI-6.0-RHEL-7-20160208.1-RHCI-x86_64-dvd1.iso
RHCIOOO-7-RHEL-7-20160127.0-RHCIOOO-x86_64-dvd1.iso

How reproducible:
Always

Steps to Reproduce:
1. Do a successful deployment using restricted network access for syncing content
2. Go back to step 'Content Provider'
3. Choose to upload different manifest file

Actual results:
Different manifest file can successfully be uploaded for completed deployment

Expected results:
The manifest upload option should be greyed out for successful deployments

Additional info:
Comment 5 Tasos Papaioannou 2016-08-25 15:42:13 EDT
Verified on QCI-1.0-RHEL-7-20160824.t.1.
Comment 7 errata-xmlrpc 2016-09-13 12:26:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.