Bug 1308457 - FTBFS: missing ExclusiveArch: %{mono_arches}
FTBFS: missing ExclusiveArch: %{mono_arches}
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: restsharp (Show other bugs)
23
s390 Unspecified
medium Severity high
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-ExcludeArch-s390x
  Show dependency treegraph
 
Reported: 2016-02-15 04:45 EST by Karsten Hopp
Modified: 2016-02-29 00:25 EST (History)
1 user (show)

See Also:
Fixed In Version: restsharp-105.2.3-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 00:25:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2016-02-15 04:45:17 EST
Description of problem:
restsharp fails to build on s390 due to mono not being available on that arch.

Version-Release number of selected component (if applicable):
restsharp-105.2.3-3.fc23

How reproducible:


Steps to Reproduce:
1. s390-koji build --scratch f23 restsharp-105.2.3-3.fc23.src.rpm
2.
3.

Actual results:
DEBUG util.py:399:  Getting requirements for restsharp-105.2.3-3.fc23.src
DEBUG util.py:399:  Error: No Package found for mono-devel
DEBUG util.py:399:  Error: No Package found for nunit = 2.6.4

http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2076006

Please add 'ExclusiveArch: %{mono_arches}'
Comment 1 Raphael Groner 2016-02-15 05:04:30 EST
Thanks for filing this bug. 

We obviously need to add this to the mono guidelines. It concerns generally all mono packages.
Comment 2 Fedora Update System 2016-02-18 06:57:39 EST
restsharp-105.2.3-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-eedc45335e
Comment 3 Fedora Update System 2016-02-21 13:00:08 EST
restsharp-105.2.3-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-eedc45335e
Comment 4 Fedora Update System 2016-02-29 00:25:15 EST
restsharp-105.2.3-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.